Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Arlo Pro Geofencing Home Mode Putting The System on Disarm

Discussion stats


Since recent update of the android app or arlo backend system geofencing no longer working as intended  (since 15/05/2018). I can select Geofencing and it accurately selects "home" mode. However, rather than selecting the correct arlo mode, the system just "disarms" . I have tried many mode pointing towards "home option" it still does nothing. The app or web interface used to show corresponding mode selected based on Geofencing programming. Now just shows a "location" icon. 


I would like to know if this is an isolated event or widespread. If you are using geofencing, please ensure that the system is behaving the way you intended. If not, report back here your experience. 


As a workaround, I have been using "schedule" or manually selecting specific modes. It has been working so far. 


To test out the problem; I have tested it to both of my ARLO systems (under 2 different logins, 2 separate systems) . Both of the system suffers same problem (geofencing home mode "disarms")


Phone: Samsung Galaxy S7 edge

Cameras: Arlo Pro

App - Android 2.5.0_21265


Im suffering from same issue. I’ve tried creating additional home modes and associated them with geofencing and it still disarms regardless if I’m home or not
Hopefully a fix is on the way


On my system, Geofencing when at home runs a scheduled mode (which always has my cameras in some form of "Armed" mode), and when in away mode has a custom armed mode.


Recently I am seeing the issue when switching from Geofencing to Disarmed and then back to Geofencing. Once I have switched back to the Geofencing, the "At Home" mode is always set to disarmed until I go into Geofencing, set the "Home" mode to something different, save the new Geofencing, then change Geofencing "Home" back to scheduled and save that setting. At this point it works properly.


So in recap, I should be able to switch between Geofencing and Disarmed modes without issue which I have been able to do until recently.

A workaround to correct the problem:
1) Edit the Geofencing mode
2) Change the Home mode to Armed
3) Save the change to the Geofencing mode
4) Edit the Geofencing mode again
5) Change the Home mode to Scheduled (or whatever your preferred mode is)
6) Save the change to the Geofencing mode
7) Note that the home mode is now running whatever your preferred mode is set to


Hopefully they get a fix soon as that is a lot of steps to go through for something that should be really simple. I have been running this way for over a year and a half with no issues until the last update occurred.


To Arlo Developers, when are you ging to fix the stupid Geofencing problem? It keeps on reverting to disarmed,  it's virtually useless!!!


Moderator can you please let us know if this is even being looked into? This is just effing annoying. I am seriously thinking of just dumping this useless toy.



I would also like to report this bug.  I believe it is related to the most recent app updates (2.5.1 and 2.5.2), at least for iOS.  I have noticed that the status in the "Mode" tab shows the system as "Disarmed" when in away mode when the Geofencing is setup to have the mode set to a Custom Mode (ie: only outdoor cameras).  The interesting thing is that while the status shows "Disarmed" the app actually works as intended sending me notifications when the outdoor cameras are triggered.  If I set the Away Mode to "Armed" it will correctly change the status, but if I select any custom mode the status lists as "Disarmed".  I believe the app does not correclty assign the Custom Mode status in the description, but actually works as selected even though the description of the current status is incorrect. 


The reason I think it is a bug related to the new iOS apps is because my wife's phone works correctly but her apps aren't set up to update automatically and her ARLO app is the older version. 


To recap the bug:

-Geofencing set for Home=Schedule (Disarmed during the day, Armed at night), Away=Custom Mode (Outdoor cameras only)

-When I leave the geofencing zone, the app correctly senses that I have left, sends me a notification of switching to Away mode, Enabled Devices in Geofencing settings shows device as "out of zone"

-Mode status incorrectly shows the system as Disarmed instead of Custom

-Funtionality correctly works as Custom sending notifications in Away mode of Outdoor Cameras.

-If Away Mode is set to any of the preset settings (ie: Armed, Disarmed, Schedule) the correct status is displayed, but any Custom Modes only show status as Disarmed rather that the correct Custom Mode.

-Bug first appeared in iOS 2.5.1 but still present in 2.5.2

-Bug not present in 2.4.9 or 2.5.0

-Both phones are Apple 8 plus running iOS v11.4





I am running Android 7 on a Motorola G4 phone when I am seeing this problem. On my phone it shows as disarmed and it really is disarmed as I no longer get notifications or videos when motion occurs until I go through the steps mentioned in my previous post to get it back working correctly.


So... for me at least, it is not only showing disarmed, it really is not functional.




I'm having the exact same issue as everyone else. I have an samsung S9+ and when i set up geofencing it activates disarm in home mode (as i have it set up) and activates a custom away mode when both my wife and i are out of the house. However when we are away it shows on the app that the system is dissarmed on the base station. This is really annoying and i have to manually arm and disarm the system. Any fixes?

I have the same phone and I have kind of the same problem, with geofencing when i exit my house the system insted of switching to away mode it disarm itself very anoying

Opened a chat session with support, they went away for about 10 minutes and when they came back it worked, I guess.  I did have it in my At home mode for that 10 minutes.  May have had something to do with it.  But at least for the moment mine is working.



Any solution on system always on disarmed with Geofencing?


So when geofencing is in away or home mode, select that mode, and change say from armed or custom to a different custom, save, then go back into geofencing setting, change that to the mode you want. Keep swapping between mode until it says the correct mode in status when you're at home or away.


This is a serious bug and I just got the arlo pro 2 yesterday.


Any idea when dev can fix this glaring security flaw?


I'm also giving 2 other person access.


Stilll experiencing this issue as of 9/27/2018. Can Arlo Support/Developers please respond to this thread on when we will get a fix for this? This is a serious security issue that the settings for home mode are not being followed for geo fencing.

Arlo Moderator
Arlo Moderator

The Arlo development team is currently investigating this issue. We will provide an update as soon as we have more information to share with the community.


You guys need to fix this crap I just realized the same thing is happening for me.  I rely on this system for security while I am on travel and my wife and son are home alone.  I'm about to scrap the whole thing and tell every person I know never to buy this POS.  Your support is lackluster and I have been in the software development game for over 20 years.  I'm amazed Costco still sells your product, I'm going to start contacting Costco about this now since you guys haven't done anything to fix major issues such as this and the ability for Iphone users to customize their alert tone.

I think I have a definitive solution to a stable geofencing setup. I am using an iPhone 6s and my wife has a 6s plus. I have the master account and i granted access to my wife with basic access.

On the iPhone
NO special characters for my wife’s 6s plus or my 6s. I am running iOS 12.1.

Allow notifications - ON

Location - ALWAYS
Contacts - ON
Background app refresh - OFF Unavailable
Cellular data - ON
Location In/Out - ON
Classic UX - OFF

Location services
Location services - ON
Share my location
Share my location - ON
From this device
NOTE - this stuff under Privacy seems to be the stuff that fixed geofencing for me. Has been stable for 2 days.

In the Arlo App

Base Station
Enables devices
My 6s
My wifes 6s plus
NOTE - no special characters
Away mode - Armed
Home mode - Schedule
Push notifications - this device

Grant access
Wifes 6s plus - NO PRIVELEGES

hope this solution works for others. I think the privacy stuff is what fixed my issue.
I have two Arlo base stations. My second one uses geofencing properly. The first one doesn’t and it is just the same as others users described: I have a custom mode I want to use for ‘home’ but instead Arlo always sets the mode to disarmed. I learned this the hard way as I went to look for recordings and found nothing from the last week.