Arlo|Smart Home Security|Wireless HD Security Cameras

Arlo Pro Email Notification Delay

Reply
Discussion stats
KbergIN
Aspirant
Aspirant

For the past 2 days, we've been having a 2 hour delay in receiving notifications from our Arlo Pro system. I have 2 different email accounts on my iPhone 6, one is Gmail and both been working great until a few days ago. Nothing has changed in our schedule. Our delayed notification emails will state the actual time the cameras were triggered but the email arrives 2 hours late.

1 ACCEPTED SOLUTION

Accepted Solutions
JamesC
Community Manager
Community Manager

A cloud update has been deployed that should resolve this issue. Please let me know if you continue experiencing delayed content.

 

JamesC

View solution in original post

55 REPLIES 55
jguerdat
Guru Guru
Guru

You can check the full email headers to see where the slowdown is occuring.  In the past, it appears to be an issue leaving the Amazon AWS servers but we have no idea why.

 

You may want to enable push notifications so you get timely notifications.

jz100
Aspirant
Aspirant

I have experienced alert delay of a few hours since several days ago. Today I got the email at 9:13 pm for a detection time stamped at 6:39pm. The video also did not show up in the library tab of the ios app until much later than 6:39pm. This renders the detection useless. Please look into this issue. We had used the arlo for about a year with no issue until about a week ago with this disabling delay of alerts. 

JamesC
Community Manager
Community Manager

jz100,

 

I have not been able to replicate this issue. Are you still seeing this behavior?

 

JamesC

jz100
Aspirant
Aspirant
Yup. Even today. I got an email alert at 1:04pm for an event that happened at 10:47am.
jz100
Aspirant
Aspirant
Also it does not happen with every alert. Perhaps 60% of all alerts are delayed by 1 to 2.5 hours. The ios app also alerts immediately. But when I open the app, there is no new video (until after the delay). Email and video are delayed together. Thx for looking into this.
KbergIN
Aspirant
Aspirant

Still getting delays but today, we're getting instant email notifications on one of our cameras but the other one still is delayed (usually about 2 hours). A week before this happened, we did get a new router. Had a cheap Belkin before and got a Netgear R7000 (Nighthawk). At first we thought maybe that was the problem but the cameras worked okay for about a week and then the delay began and still has continued to this day. I get Gmail notification and a diffferent POP email. Both are delayed simultaneously which makes me think it's a server issue. But today we're getting current notifications on one and not the other. The only other think I recall is that we tried moving a camera a little to the left one day and it went offline and then we got it back and that is the one we're having problems with today. May just be coincidental. Gets frustrating! I've read where some have removed all cameras and re-installed them. Should we try that?

jguerdat
Guru Guru
Guru

I don't see how a camera could cause the delay.  Check the full email headers (post them here if you like) to verify that the server sent the email but the email service you used didn't receive them for a long time.  That's what we've seen before which is a backend issue, not camera or base.

jcwrks
Luminary
Luminary

jz100 wrote:
Also it does not happen with every alert. Perhaps 60% of all alerts are delayed by 1 to 2.5 hours. The ios app also alerts immediately. But when I open the app, there is no new video (until after the delay). Email and video are delayed together. Thx for looking into this.
  • Remove camera from app
  • Remove battery from camera
  • Reboot the base
  • Sync camera to base
lmsattler
Aspirant
Aspirant
I have recently been having the same problem. I have two different Arlo systems at two different locations with different email servers. The problem started about 2 weeks ago- slowly and in 1 case it started on just 1 of the 3 cameras. Now it is becoming more frequent and in the case of multiple cameras the delay has spread to two of the 3 cameras. This eliminates the router and the server as the problem unless multiple servers are malfunctioning at the same time. Is it possible the video could be getting hung up somewhere between the Arlo system and the email server? This problem does not happen with every single video but it is increasing in frequency. Thanks for looking into this problem.
TimTexas22
Aspirant
Aspirant

Were you able to resolve the issue? Im having the same problem with 4-5 hour delays in receiving the video and email.  Thanks,

 

 

KbergIN
Aspirant
Aspirant

Nothing resolved. Arlo push notifications work but both the video appears in library and email notifications are usually 2 hours later. Has been that way for several weeks consistently. The time stamp on the library video and email are both accurate in the time the motion was detected but delivery is 2 hours late. Very disappointed. Have considered removing everything and starting all over again but not sure if that will resolve.anyone else got any ideas? 

jz100
Aspirant
Aspirant
Did the following:

Remove camera from app
Remove battery from camera
Reboot the base
Sync camera to base

Seems to be better. I would recommend you all try these and let all know whether it works. I had six alerts. I am pretty sure nothing came later than an hour. Emails seem to have two time stamps. One on ios email app. Another inside the email. Ios email time stamp can still be late. But all six had inside email time stamp matching the alert video timestamp. Sorry for the confusing description here. Will report back back when I have a few more days of experience. Jz
jz100
Aspirant
Aspirant
Just experienced a 3 hour delay. Jcwrks, the steps you recommended did not work. At this point I believe netgear is having a delay issue on its side. Please advise as the cameras are no longer dependable as security measures. This is a serious flaw and I hope netgear can solve it with high priority. Jz
SMG_cville
Aspirant
Aspirant

Here the same thing. Was in contact with arlo support and they kind of blamed it on my internet provider.They also had me change my email address which didn't resolve the problem. That problem seems to have occurred last year too and then they were at least so open to inform the forum that they had difficulites with one of their cloud servers.

jz100
Aspirant
Aspirant
Still same issue. Arlo, could you take responsibilities and at least acknowledge the issue and work on a fix? Disappointed by the silence so far.
KbergIN
Aspirant
Aspirant

It's 11:30 a.m. now, and my Library still doesn't yet show my husband leaving the house at 5:45 a.m. Library says "No recordings". ! Usually it has taken about 2 hours to show. This is ridiculous! A lot of money spent for a product that doesn't deliver what it promises. At first it worked like a charm, but for several months now my email notifications and delivery of the recording to the Library are delayed for hours!

JamesC
Community Manager
Community Manager

I have escalated this topic and engineering is currently investigating. I will post an update when I have more information.

 

JamesC

Octrojam
Tutor
Tutor

Been having the same problem as well.  Push notifications coming hours after the detected event. My phone just went off and when I logged in, the app showed the most recent event as occurring 2 hours ago.  It's been this way for at least a month, maybe longer. 

mcmu12
Luminary
Luminary

Same issue for me.  I posted the same problem on another string but want to see if the answer is found on this string.  

oldfella
Aspirant
Aspirant
Problem is in Netgear Servers.....have had 4 Arlo Cameras for nearly two years working perfectly & immediately sending emails. However I changed from using Apple iOS to an Android Handset a few months ago & this is when the immediate Arlo Alerts to the APP ceased & email delays started. I think their SERVER works with the APPLE iOS APP perfectly as when I use my Apple handset the immediate notifications to the APP work but the ANDROID handset APP arrived hours later.
Netgear need to look at the APP for ANDROID devices.....
jz100
Aspirant
Aspirant
Oldfella, I use ios phone. So I donot think it is issue with Android app. The delay affects ios app.
oldfella
Aspirant
Aspirant
Well I can only comment on what I know....my Apple iOS Phone works great with the Arlo App, however my Android Phone does not and I get a few hours delay on receiving email notifications and never receive in APP notifications even though all the Permissions have been allowed on the ANDROID Phone. This is why it is a Server or App issue as so many of us are having problems.
paulmike3
Apprentice
Apprentice

This issue has been happening for me for several days now. I've also been getting motion detection alerts and nothing recording.

 

Email with delay timestamps

jgsouthard
Apprentice
Apprentice

I've posted regarding this issue before, but it's obviously back again. I've been using nine Arlo wireless cameras in two locations over the last couple of years, and I've come to two pretty definitive conclusions:  1) On Android phones (no experience with iOS), notification alerts work just fine and are nearly instantaneous. 2) Email alerts are worthless, and the problem IS with Netgear servers and NOT my email provider (Gmail), despite Netgear's protests to the contrary. That seems obvious given how many people are seeing the issue, but it seems to have taken Netgear way too long to accept. I am not experiencing email delivery delays with ANY other senders other than Arlo.

 

The issue is definitely worse in the last month or so, but there was a similar period back when I first started using the cameras, and the issue seems to come and go. Delays in email alerts of 2-3 hours are not uncommon at all, and I've seen delays of as much as 12 hours. And it appears to be totally random (NOT first-in, first-out). A few days ago I had a motion event followed rapidly by another motion event. I got the second one within a minute or two (that's about the best case), but the FIRST one didn't show up for another 12 hours.

 

I like the fact that the email alerts show me all recent alerts (i.e. one email for each alert), including a screen shot from the video and a link to a live feed; but the time delay is making them pretty useless. Although the notification alerts come quickly, they are much less useful since only the LAST alert is shown, with no screen shots or links. If I get several alerts, I can't tell which cameras they are coming from (other than the last one) unless I open the Android Arlo app, which is a SLOW process. I'd love for the notification alerts to show me a tally of the last several alerts (say 5-10) in the last notification, so that if I'm getting multiple triggers on one or more cameras I can at least tell where they are coming from.