Arlo|Smart Home Security|Wireless HD Security Cameras

Geofencing is completely broken in the new APP

Reply
Discussion stats
baumbachaflocka
Follower
Follower

The old app worked great with geofencing, it would not arm unless every device left the area. Now it always arms if just 1 person leaves. My system is configuration is the following: anyone arrives> standby, everyone leaves> arm away

They are both set to always enabled and I have made sure that both my devices are setup correctly with always allowing precise location, notifications and do not have battery saver on. Its so frustrating because the old app worked great and the new one is so bad and we were forced to switch when we added the new cameras.

 

More info there is 1 iphone and 1 android phone used for geofencing, I have it set to the largest area and no other automations except for the geofencing ones.

63 REPLIES 63
ShayneS
Arlo Moderator
Arlo Moderator

Please reach out to the Support Team to further investigate this issue you are experiencing. You can find several options for contacting support though the Arlo Mobile App by navigating to the Profile icon > Support Center > Select device > contact

Johanwiltvank
Initiate
Initiate

Same here. And in my experience, the camera's are constantly armed. Even when all persons are present.

jcplonghorn
Tutor
Tutor

Same here. One of the two designated people (devices) leaves, and randomly throughout the day, the indoor cameras are recording even though the one person is home. The mode is set for only outside cameras when we are home. This is a recent problem with a recent app update or firmware update on the cameras, not sure which. It had worked perfectly for years. 

ShayneS
Arlo Moderator
Arlo Moderator

The Arlo development team is currently investigating this issue. We will provide an update as soon as we have more information to share with the community.

Bah0482
Apprentice
Apprentice

I am also having geofencing issues. Same experience worked fine until the new app. Geofencing is one of the main reasons I own arlo cameras. Good to know they are aware but they need to communicate to users more that they know of this issue. 

jcrain
Apprentice
Apprentice

Hi, I can't seem to configure Schedules and Automations to work seamlessly.  I thought I had set this up correctly, but on a recent trip away from home, we discovered that the app was not switching modes as I had thought.

 

I want the Geofencing to work at all times, and the Schedules to work when we are home. In the old app this was easy to set up.

 

In the new app, the scheduling is not recognising our geofencing location once the schedule expires. So we've been away and the cameras have switched off in the morning, despite us being away. If I flip the logic, the cameras remain on, even though we are still home.

 

Want I want to do:

  • At 11pm each night, turn on all cameras, if they are not already on because of geofencing.
  • At sunrise, turn off all cameras, but only if we are home.

With geofencing, Arm Home when anyone arrives home. Arm Away when all Leave.

 

Can anyone please assist?

 

 

StephenB
Guru Guru
Guru

@jcrain wrote:

 

Can anyone please assist?

 

 


If you remove automations for geofencing, does the schedule work as desired?

jcrain
Apprentice
Apprentice

No.

If I change the schedule to Arm Away at the end of the schedule, the cameras remain on, even when we are home.

 

If change the schedule to Arm Home at the end of the schedule, the cameras switch off, even if we are away.

 

Basically, the geofencing doesn't work once the scheduling ends regardless of our location. Maybe I've set it up wrong.  I have to say, like other users, the interface is not intuitive at all. e.g. When scheduling ends, I'd expect an option to resume to normal geofencing, instead I have to select Geo Leave, Geo arrive, Arm Away or Arm Home. None of these behave correctly.

StephenB
Guru Guru
Guru

@jcrain wrote:

 

If I change the schedule to Arm Away at the end of the schedule, the cameras remain on, even when we are home.

 

If change the schedule to Arm Home at the end of the schedule, the cameras switch off, even if we are away.

 


I'm not certain what you mean by "change the schedule".

 

Feed uses a different model for scheduling (scheduling an event to change the mode), so you do need one automation for each transition point.  One automation to switch to Arm Away whan you want to shift to that, and a second automation to switch to "Arm Home" when you want to switch to that.

 

Is that you've set up?

jcrain
Apprentice
Apprentice

I mean "add" a schedule.

 

Sorry but I don't follow the rest of your post. 

 

All I want to do is have the cameras on between 11pm and Sunrise everyday no matter what. For all other times, it should be choosing mode based on geofence location. There is no option to do that, that I can see, unlike the old app.

StephenB
Guru Guru
Guru

@jcrain wrote:

 

All I want to do is have the cameras on between 11pm and Sunrise everyday no matter what. For all other times, it should be choosing mode based on geofence location. There is no option to do that, that I can see, unlike the old app.


I suggest reading the link I posted.

 

To set up the schedule you need to set up two automations.  One to trigger armed home (or armed away) at 11 pm, and another to trigger standby at sunrise.  Have you done that step?

jcrain
Apprentice
Apprentice

Yes, I have a schedule set for 11pm Arm Away, and another for Sunrise (currently Arm Home as per the article but it doesn't work as we need. If we are not Home when the schedule triggers at sunrise, the geofence doesn't recognise this and the cameras turn off anyway).

 

Why are you suggesting Standby for the second schedule?

StephenB
Guru Guru
Guru

@jcrain wrote:

 

Why are you suggesting Standby for the second schedule?


Perhaps I am misunderstanding what behavior you wanted. It sounded like you wanted the cameras to be turned off at sunrise.  So I suggested standby.  But the modes are editable, so you could use a different mode to turn them off.

 

I do think you'll get this sorted out more quickly if you work on one element at a time.  I was thinking that getting the schedule to work correctly first, and then adding in geofencing was the best way - but I am seeing at a thread from last fall saying that they needed to set up Arrive/Leave automations first in order to get it to work properly.   That does make sense, since you'll need to have exceptions in the time schedule to prevent geofencing from turning off the cameras between 11 pm and sunrise.    

jcrain
Apprentice
Apprentice

At sunrise, I'd like the cameras to use our location/geofencing to determine if we are home (turn them off) or away (leave them on).

 

There does not appear to be a way of doing this. I am forced to choose a Mode, or Geofencing Leave or GeoFencing Arrive. None of these are suitable or work as I would expect. 

StephenB
Guru Guru
Guru

@jcrain wrote:

 

There does not appear to be a way of doing this. I am forced to choose a Mode, or Geofencing Leave or GeoFencing Arrive. None of these are suitable or work as I would expect. 


FWIW, I agree this is quite complicated (and likely buggy at the moment).

 

I am not certain that I completely understand what you want.  But I am thinking that you

  1. want the cameras on between 11 pm and sunrise whether you are home or not
  2. want the cameras enabled whenever you are away
  3. do not want the cameras enabled between sunrise and 11 pm when you are home 

Is this a complete description of the desired behavior?

jcrain
Apprentice
Apprentice

Correct.

 

The issue appears to be what happens at the end of the sunrise schedule. After sunrise, how do we get the app to test our location using geofencing and enter the correct mode (Away if not home, Home if at home)?

StephenB
Guru Guru
Guru

@jcrain wrote:

how do we get the app to test our location using geofencing and enter the correct mode (Away if not home, Home if at home)?


You don't.

 

Have have you tried the instructions in post 4 here:

Arrive/Leave:

Home Anyone Arrives > Always Enabled, WHEN Anyone Arrives THEN
   Home Nighttime > Enable
   Home Daytime > Enable

Away Everyone Leaves > Always Enabled, WHEN Everyone Leaves THEN
   set Arm Away (Mode)
jcrain
Apprentice
Apprentice

I have entered that setting that and will see what happens in the next 24 hours.

 

If that is how to set this up, then that is completely counter-intuitive to me, based on the UI design and previous app versions. I would never have tried that approach...Let's see!

 

 

StephenB
Guru Guru
Guru

Note also post 8 in the same thread

 

In the 'Day' automation:

'Day Time' = Arm Home [or whatever mode you want];
Schedule > When: > Sunrise or Custom time
CREATE THIS EXCEPTION ~ 'Then' = 'Leave*' automation is set to ENABLED.
That way, if you go out, through the day, it will trigger your 'Arm Away' mode. If you come back, it will switch to 'Arm Home' mode [or whatever modes you want to select based on how you use your modes].

 

In 'Night' automation:

'Night Time' = Arm Away [or whatever mode you want];
Schedule > When: > Sunset or Custom time
CREATE THIS EXCEPTION ~ 'Then' = 'Arrive*' automation is set to DISABLED.

  


@jcrain wrote:

 

If that is how to set this up, then that is completely counter-intuitive to me

 


Agreed.  The basic principle is to selectively disable/enable automations.  The logic you need to get the behavior you want when you combine geofencing and scheduling is too complicated.

 

The approach in the old app was flawed too, and many found it confusing.  But IMO this is harder, not easier.  It needs to be redesigned.

 

jcrain
Apprentice
Apprentice

Doesn't work. 😞

 

At sunrise, the mode stays on Arm Away, so I have to manually switch it to Arm Home. Also, I don't get notified about anything even though I've asked it to.

 

To confirm, the current setting is:

Geofence arrive home -> Always enabled.

WHEN Anyone arrives

THEN Arm Home, All on at night (11pm) - Enable, All off at dawn (sunrise) - Enable, Send notification.

 

 

 

jguerdat
Guru Guru
Guru

I've tried using those settings and found it didn't work. I'm not sure why it works for some and not others but I have to use Change Mode for my schedules.

jcrain
Apprentice
Apprentice

OK, I can find no way to get geofencing to work after a schedule expires. So I've gone back to basics and accept that the app won't actually work the way it used to, or how I need it to.

 

I now tell the app to return to Arm Home at the end of the night schedule and if I ever leave the house during the schedule I will manually switch it to Arm Away. 

 

Arlo Support is frankly useless. They repeatedly send links to the same articles over and over without actually understanding the problem.

 

ShayneS
Arlo Moderator
Arlo Moderator

Hi @Bah0482 

 

Are you still experiencing this with Geofencing?

jcplonghorn
Tutor
Tutor

YES. Same issue going on months now. 

Discussion stats