Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Broken Product and Extremely Poor Customer Service

Reply
Discussion stats
  • 12 Replies
  • 487 Views
  • 2 Likes
  • 6 In Conversation
llindse
Guide
Guide

I purchased an Arlo Pro 3 Floodlight due to an increase in crime in my area.  The camera stopped working after 5 months and after 44 hours on the phone with 3 different technical support specialists, all troubleshooting options were exhausted and the camera still did not work. Support claimed I would receive an e-mail regarding an exchange in which they would send me a new camera, but not a new battery. I did not receive an e-mail regarding this and I still have no camera. My family uses Arlo and I have suggested Arlo to my friends because it has been an excellent purchase thus far, but now I am questioning Arlo due to the lack of customer service and support. What do I have to do to get a working camera? It has been 5 days now.

Model: VMC4040P | Arlo Pro 3 Wire-Free Camera
12 REPLIES 12
Streak2
Master Master
Master

Do you have a case number from support so that Arlo can follow up?

 

llindse
Guide
Guide
Yes, I received a case number and would love to follow up to resolve this issue and continue with Arlo.
dcfox1
Master
Master

Post the number and a Mod may follow up. No personal info though. 

llindse
Guide
Guide
Appreciate it! Case #42494927
JamesC
Community Manager
Community Manager

llindse,

 

Thank you for the case number. I've escalated your support ticket and requested that an agent reach out to you with a status update.

 

JamesC

StephenB
Guru Guru
Guru

@llindse wrote:
Appreciate it! Case #42494927

Looping in some mods, to hopefully speed up the followup.  @JamesC , @JessicaP , @ShayneS 

 

llindse
Guide
Guide

Thank you. I enjoyed my Arlo product the first 5 months it was working and am hoping to continue. I paid for overnight shipping for a new camera and this one is not working either. 

JamesC
Community Manager
Community Manager

llindse,

 

When you say the camera is not working, what exactly are you experiencing? At what point do you see an issue? Are there any error messages?

 

JamesC

llindse
Guide
Guide

Hi JamesC,

 

When connecting the camera, it will successfully connect to the 2.4 ghz network, blink blue, scan the QR code and make the chime noise, but the device is never found.

 

Thanks!

JamesC
Community Manager
Community Manager

llindse,

 

Try factory resetting the camera, press and hold the sync button (~15 seconds) until the LED flashes amber and the camera reboots. Then try setup again, be sure you're entering your network SSID and password exactly as it appears in your router settings.

 

JamesC

llindse
Guide
Guide

I've already exhausted the list of troubleshooting options with technical support across 5 hours and various phone calls this week. I tried factory resetting again as you explained and it will still not discover my device.

rl93
Aspirant
Aspirant

I have the exact same problem with my floodlight, except I've only had it for 3 weeks. Spent an hour on the phone troubleshooting without any luck. They offered to send me a new one after I mailed them the old one. However, they are requiring that I PAY for shipping back to them for THEIR defective product! I never even got the confirmation email as to where to send it, I had to call again for the address. They should provide a shipping label free of cost. Absolutely terrible customer service model. 

 

Case number: 42524087

RMA 7189485

Model: FB1001 | Arlo Pro 3 Floodlight
Discussion stats
  • 12 Replies
  • 488 Views
  • 2 Likes
  • 6 In Conversation