Arlo|Smart Home Security|Wireless HD Security Cameras

No Live view in Firefox on Windows 10 for the Pro 2. Works on Edge and Android Phone.

Reply
Discussion stats
  • 8 Replies
  • 182 Views
  • 1 Like
  • 3 In Conversation
Highlighted
Aspirant
Aspirant

NO LIVE VIEWING IN FIREFOX... It works in Microsoft Edge and on android phone. Running Windows 10 with latest version on Firefox. I am so tired of reading and trying the same things over and over again to no avail. Arlo says it works best with Chrome and Firefox.. I dont use Chrome, but it works in Microsoft Edge... Go figure...It works in something they Dont support and doesnt work in something they do support... Something is WAY OFF here. Really tired of getting no-where with this.

 

                                                                  HELP!

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera

Accepted Solutions
Highlighted
Aspirant
Aspirant

GOT IT! That was it. I restarted Firefox in safe-mode to disable all add-ons and the video works. Now to find the add-on that is blocking it which is no problem. I knew it had to be so simple on something I was over-looking, that's what frustration does to you. Thanks for the clue!

View solution in original post


All Replies
Highlighted
Guru Guru
Guru

@LitleJoe wrote:

NO LIVE VIEWING IN FIREFOX...


I just checked, and I am able to livestream my pro2 cameras with firefox.  This is on a Windows 10 PC, the FireFox version is 76.0.1.

 

Note that Arlo is no longer using flash with your cameras, so information here related to troubleshooting flash no longer applies.

Highlighted
Sensei Sensei
Sensei

@StephenB wrote:

I just checked, and I am able to livestream my pro2 cameras with firefox.  This is on a Windows 10 PC, the FireFox version is 76.0.1.

 

 


Same here. Working as expected.


Just another user
Arlo hardware: Q Plus, Pro 2 (X2), Pro 3 (X3), Security Light (X2), Ultra (X2), Doorbell, Chime
Highlighted
Aspirant
Aspirant

Just checked my version of firefox and it is 76.0.1 (64 bit) in windows 10. Still no live video. I uninstalled flash player but still nothing. I can playback what was recorded but thats it. Interesting thing is my little netbook running windows 10 with firefox v76.0.1 views live video. Must be an old driver or something left over on my home pc preventing it from working. All I know is that I am half bald now from pulling my hair out trying to figure this out. Its got to be something simple.

Highlighted
Guru Guru
Guru

@LitleJoe wrote:

Just checked my version of firefox and it is 76.0.1 (64 bit) in windows 10. Still no live video. I uninstalled flash player but still nothing. I can playback what was recorded but thats it. Interesting thing is my little netbook running windows 10 with firefox v76.0.1 views live video. Must be an old driver or something left over on my home pc preventing it from working.


Do you have internet security or an ad blocker running on the problem PC?

Highlighted
Aspirant
Aspirant

GOT IT! That was it. I restarted Firefox in safe-mode to disable all add-ons and the video works. Now to find the add-on that is blocking it which is no problem. I knew it had to be so simple on something I was over-looking, that's what frustration does to you. Thanks for the clue!

View solution in original post

Highlighted
Sensei Sensei
Sensei

@LitleJoe wrote:

Now to find the add-on that is blocking it which is no problem.

 


Good research Sherlock.

 

For the benefit of others, it would be great to know which app caused that grief.


Just another user
Arlo hardware: Q Plus, Pro 2 (X2), Pro 3 (X3), Security Light (X2), Ultra (X2), Doorbell, Chime
Highlighted
Aspirant
Aspirant

Well I had to have time to get back on my computer and post, but I found the problem add-on.

 

"FVD Video Downloader"

 

I had a couple of downloaders, I disabled all of them and one by one enabled them and that was one. I'm sure other add-ons can cause problems too but just start Firefox in safe-mode and that will let you know. Hope this helps.

Highlighted
Sensei Sensei
Sensei

Great feedback.

 

Have you come across this trick for debugging apps?

  • Disable half of them
  • If the bug persists
  • Enable those
  • Disable the other half
  • Confirm that the bug is dead
  • Disable half of those still active
  • .... repeat process until you have homed in on the culprit.

Quicker than going through them one at a time.

 

 

 

 

 


Just another user
Arlo hardware: Q Plus, Pro 2 (X2), Pro 3 (X3), Security Light (X2), Ultra (X2), Doorbell, Chime
Discussion stats
  • 8 Replies
  • 183 Views
  • 1 Like
  • 3 In Conversation