Arlo|Smart Home Security|Wireless HD Security Cameras

Initial impressions on new purchase, mixed feelings

Reply
Discussion stats
  • 0 Replies
  • 365 Views
  • 2 Likes
  • 1 In Conversation
Highlighted
melnok Tutor
Tutor

Bought an Arlo Pro 2 base station with two cameras and set them up yesterday. The system has a lot of promise, although I am not sure what to do now, after a few days of evaluating.

After installation, there are a few flukes that put me on the edge of if I can trust the system, or if I should return the purchase. Here are my observations. I am hoping if someone knows if these are known issues, or has any good workarounds.

1. Setup was smooth, although the firmware update experience was a bit buggy. After initiating the firmware update on the base station, there was no clear update progress or status notification, and after waiting for several minutes to get a "update complete" notification, I instead was taken back to square one with the same popup on my phone that I need to update the firmware (which the box just had done/was in the middle of doing?), but the UI just froze when I tried to tap the update button again. After waiting for some half an hour, and reinstalling the Arlo app, it recovered.

 

Firmware updating the cameras was a smooth process.


2. I wanted to set the push notification tone to a loud alert sound in my mobile phone, instead of the default Android system "text message" sound, that is not very alerting - I am afraid that I would miss an activity immediately if I kept the default text message sound. On my Huawei P10 Plus with Android 8.0.0, in Arlo app's Settings->System->Notifications, adjusting Notification Tone, LED Color and/or LED Blinking Frequency does nothing. No matter what I set the values to, I still get the default Android incoming text message audio when activity is detected. This is a big problem for me.

 

I wonder if this is a Huawei specific thing and I should change the phone I am using, or if this is a known issue on all Android phones/version 8.0?


3. Tried contacting Arlo support on their website, there was a "Chat with Us" button there. However accessing that redirected to a salesforceagent.com URL, which kept rolling a "Connecting you with an agent" progress indicator, and after two instances of ~20min-30min waiting (one on mobile phone Firefox, another on desktop Chrome browser), nothing happened, so I gave up.

4. In another attempt to contact paid support, I tried the "Drop us a Line" action in the web page, in order to report bug #2 above. However halfway writing up a bug report into the web form in the page, the web form simply vanished from the page(!!) while I was still writing into it, leaving only "Have you tried our knowledgebase" and "Ask the Arlo Community" links in the page.

If I purchase a close to 600 EUR product and admit a 20EUR/month plan, I would expect to have a solidly working method to report a bug and at least be acknowledged by the development team with issues I am facing, and not chat links that hang infinitely long, and feedback forms that vanish from under you. This is critical for any closed source/monthly plan service, and left quite a bad impression.

5. Testing out how the siren feature works, I configured a custom armed Mode with siren activity on motion detection enabled. That triggered ok, and after hearing the siren, I physically pressed the Sync/Siren Off button on top of the base station for a short duration. Pressing that button did immediately stop the siren, but it also left the whole Arlo system in an odd state where it would stop detecting any further motion whatsoever in camera, and all the three leds on the base station kept blinking. After toggling between the Armed and Disarmed modes for a while to try to get the setup to recover and waving my hand past the motion sensor, I gave up and physically powered off the device and back on again. That recovered the setup.

If pressing the Sync/Siren Off button has a dual meaning of not also disabling the siren, but also disabling the device while putting it in some kind of pairing sync mode, there should be a notification of that kind of status mode being active in the phone UI, otherwise user easily thinks the setup is not working reliably.

6. The Geofencing feature does not seem to work. After setting it up and walking out and away from the zone and waiting for a while, the system did not toggle to Armed state even though I had configured it to. The setup did properly show my location outside the radius sphere and it did update it live, but the system did not report being in Armed state. This is not good at all.

7. When one configures a camera to edit Activity Zones, the instruction states "Highlight areas in your camera's view where you want to receive or ignore motion or sound alerts.". As one drags over the video feed to form one or more zones, it is not at all clear whether these zones mean Disabled states, Enabled states. Which one is it? There is no "toggle" mechanism that I can see to configure whether a dragged area is an enabled area, or a disabled area?

I.e. If I drag a rectangle over to cover the left side of the camera feed, does that mean that the left side will then motion trigger, or does that mean that the left side will be disabled from motion triggers? The overlay color of the rectangle being "darkish gray" makes me think that perhaps the rectangles define disabled zones?

8. The reason I am asking the above is because I am struggling to test Activity Zones, since after configuring Zones on my Camera 2, it looks like that has rendered Camera 2 broken and unable to report motion triggers. I edited a Zone and saved it, and the Arlo setup got again into odd state where after setting mode to Armed, motion would no longer trigger on Camera 2. When I walk across the view of either camera, I do see the "speeding ball" icon highlighting yellow, but I am not getting push notification, and nothing is recorded in footage entries in Library view. Camera 2 is powered off of USB when testing this, it is not on battery power. Going back and deleting all activity Zones to undo my test does not help - Camera 2 is no longer triggering motion at all.

Eventually I was able to undo the breakage by removing Camera 2 and re-pairing it to the base station. That got the motion triggers to work again on it. Is there a known issue with editing Activity Zones?

9. I plugged in a 2TB external USB disk drive to USB1 port, and then went in Storage Settings to enable it. However, no device was shown in that menu. After poking the UI for a while, disabling and re-enabling USB Device Recording, I could not get the USB drive to detect. Then I disconnected the disk and connected it to USB2 port, which, positively, did immediately get recognized as ADATA HV620 drive, and I could format and enable it. Are external disks restricted only to USB2 port, and USB1 is only a service port? If so, then the Storage Settings UI would be good to reflect this, and instruct user to plug storage disks to port 2 (in which case, perhaps the USB1 and USB2 ports would have been good to be labeled Storage USB and Service USB, or similar?). If both USB ports should work equally, it suggests there is some kind of bug in disk drive detection.

10. The Device Utilities -> Video Settings -> Pan & Zoom view (the one with Punch to zoom into the video) widget felt clunky to operate. It was exceptionally hard to configure the rectangle there the way I wanted to, the green corners do not seem to line up like one expects interaction to occur, and each interaction is interrupted by a 1-2 second spinner icon that saves the setting that was applied. After trying out the option, it was hard to undo my change and restore the active frame to unmodified/full 100% size of the video frame where it had been by default. Somehow when dragging the green corners, they do not want to line up back to the corners of the feed, but I end up missing few % from each corners. Perhaps there should be a "reset to full view" option to get back to the default selection state?

It was odd to see this active frame edit dialog being so clunky and poor UX to interact with, in particular because the Activity Zone edit window has a nice and smooth UX for the same purpose of dragging rectangles, so perhaps reuse that widget for the active frame editing widget? The activity frame widget came off as buggy/poorly programmed, but the Activity Zone widget was comfortable to operate.

11. On Huawei P10 Plus, the system "high battery usage" notificator keeps showing a warning icon about Arlo app consuming a lot of battery on Android. Oddly, I was not able to disable the battery usage warning indicator only for the Arlo app (this might be a Huawei/Android bug), but I had to disable it for the whole Android system, which feels uncomfortable. Is Arlo app known to be a big battery drain?

12. Performance related, there is a bug where, if one does a certain sequence of UX interaction with the app+Android system while a camera video feed is being displayed with audio, one then hides Arlo app to the background, e.g. by context switching to another app, the audio of the camera feed will stay on and play on top of any other app one switched to. In that case, one has to kill the Arlo app from Android system menu to disable the phantom audio from playing. This is minor, but still may be worth looking into.

In summary, initial impressions are really mixed, I do not know what to do. The build quality with the hardware, image quality, and near immediateness of activity reporting feel superb. However the high price of 600EUR + 20EUR/month, but seeing issues #2, #3, #4 feels critical, and issues #5, #6 and #8 are major that I am considering returning the system as unreliable. Other bugs are minor enough that are not an issue, but easily adjusted to when using. I cannot use a system where I feel that I have to do a double check act on the motion trigger system is working each time I leave, or if I have to second check if Geofencing system has activated.

Does anyone have experience with above issues? Are the extents of the flukes above known, and how to best navigate around them? Is there a known way to reach the development team, how is the update cadence, etc?

 

I was hoping for a "tight" reliable out of the box experience, but that was unfortunately a miss. Has Arlo been to you a "tight reliable experience after you learn the quirks" at least?

 

For reference, versions of my setup are

 

Arlo Pro 2 base station

Firmware 1.12.0.0_27099

Hardware VMB4000r3

 

Camera 1
Firmware 1.125.11.3_26229
Hardware H4

Camera 2
Firmware 1.125.11.3_26229
Hardware H3

 

Arlo App

Version 2.6.3_23200

Released 11/26/18

 

Huawei P10 Plus

Android 8.0.0


Thanks for reading, wish everyone a happy and safe holiday season,

M

 

Model: VMC4030P | Arlo Pro 2 Wire-Free Camera