Arlo|Smart Home Security|Wireless HD Security Cameras|NETGEAR
Reply

Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

When attemping to add an Arlo Pro 2 camera to smartthings using the Arlo (Connect) feature, when pressing Save, Smartthings will fail giving the error message "An unexpected error occured".

 

When looking in the Smartthings console, the error message is given as follows:

 

physicalgraph.app.exception.UnknownDeviceTypeException: Device type 'Arlo Pro 2 Camera' in namespace 'Arlo' not found.

 

However, several months ago I successfully added my first Arlo Pro 2 camera without any difficulties, which was recorded by Smartthings as being an "Arlo Pro Camera" (missing the 2, but the camera is certainly the Arlo Pro 2).

 

From this, I conclude that a change has been made in how the Arlo Pro 2 camera reports itself to Arlo (Connect) - previously it reported itself as an Arlo Pro camera, even though it was the later model. Now it reports itself as an Arlo Pro 2, but  Arlo (Connect) cannot find the a device handler for this and so fails.

 

Hard to tell if this is an issue for Netgear or Smartthings to solve, but I would hazard a guess that Netgear develop the Arlo (Connect) module and then the Smartthings team include this in the app.

 

Either way, it is an issue for Netgear and Samsung/Smartthings to collaborate on. 

 

And for further info, this is Hardware H3 firmware 1.124.1.0_15483 (I assume the latest as of today as it updated on first boot).

 

Model: VMC4030P| Arlo Pro 2 Wire-Free Cameraarlo.netgear.com | Web Site/App
Message 1 of 24

Accepted Solutions
Highlighted

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

Yep confirmed fixed 25/1/2018. Note that in the smartthings console the is reported as type "Arlo Pro Camera" once again, rather than "Arlo Pro 2 Camera" as it was reporting previously - so the fix seems to have been that someone has reverted the string which is reported back to Smartthings on registration.

Message 24 of 24

All Replies
brh Master
Master

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

Over on the Smartthings forum there are a lot of recent complaints about the Pro 2s not working with Smartthings. I thought this was fixed, but apparently not.

 

Brian

Message 2 of 24

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

Looks to me like it was fixed, since it worked a couple of months back when I added my first new Arlo pro 2 but broken again as of today when my second arlo pro 2 arrived in the post.

The first unit is still working fine, it is just the enrolment/registration endpoint that seems to be broken in arlo (connect)
Message 3 of 24
Master

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera


jimmarshall87 wrote:
Looks to me like it was fixed, since it worked a couple of months back when I added my first new Arlo pro 2 but broken again as of today when my second arlo pro 2 arrived in the post.

The first unit is still working fine, it is just the enrolment/registration endpoint that seems to be broken in arlo (connect)

You might be right. My existing connected Pro 2 cams show up and work fine in ST but perhaps adding new ones is broken.

Has anyone contacted support to open a ticket?

Message 4 of 24
brh Master
Master

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

@steve_t

I believe that in the past as a temporary fix they registered them as just the Pro cameras instead of Pro 2 cameras. From everything I see that is now broken.

 

Brian

Message 5 of 24
Master

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

Not sure I ever recall seeing the Device Type as "Arlo Pro 2 camera"
Forgive the scrawling. Not sure if serials can be used for anything so I drew over them anyway. You can see a mix of Arlo HD, Arlo Pro and Arlo Pro2 cameras here along with other devices

Arlo ST.jpg

Message 6 of 24
Master

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

Oh dumb. That's pretty much impossible to read. Never mind. Take my word for there being Pro 2 cameras there Smiley Wink

Message 7 of 24
brh Master
Master

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

@steve_t,

Hi Steve. I have seen you over on the Smartthings community forum under the Arlo discussions. I am sure you have read all the stuff going on in that forum about the Arlo 2 systems. I believe that is where I read about them being listed as Pros a few months ago or maybe somewhere when I Googled about the. No Sure. But there seems to be an awful lot of problems with them both natively and integrated with Smartthings. I hope a definite answer can be had soon as I was considering buying a couple. I think I will hold off for awhile.

 

Brian

Message 8 of 24
Master

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

Yeah, I'm too scared to delete any Pro 2 cameras from ST/Arlo Connect in case I can't re-pair them. I use Arlo Pro 2 to trigger lights inside and outside the house and I wouldn't want to break that integration. Hopefully a few people have opened tickets about this and if support can replicate the issue, they will fix it. One of the big drawcards for Arlo, IMO, is the integration with ST

Message 9 of 24

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

I just bought the Arlo Pro 2 and I’m running into this issue. Normally I click the arlo smartapp and just select the new camera and I’m done. But I just get the error.

When I bought an Arlo Pro 2 in December I was able to add it without an issue.

But when I bought a new one in January (aka today) I can not add it.

The camera works fine in the arlo app.
Model: VMC3030 | Arlo Wire-Free Camera
Message 10 of 24

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

Anyone from Netgear monitoring this thread then - seems more than one customer with the same issue.

Message 11 of 24
Master

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera


jimmarshall87 wrote:

Anyone from Netgear monitoring this thread then - seems more than one customer with the same issue.


This is mostly just a community of users though occasionally some staff pop by. For a definite response, people need to contact support and open a support ticket via the link at the bottom of the page

Message 12 of 24

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

Response from Netgear Support:

 

- The Arlo PRO 2 is not yet available in Smart things.

- The 1st camera you had hooked up might have been detected that it was a version 2 camera(VMC4030) but and got messed up when second camera was added.

- We have this raised in our engineering department for the software upgrade. Currently PRO 2 is not yet part of the list.

- For now we do not have an estimated time for that. But of course we are looking forward for that since Arlo PRO 2 was just released. This is to be upgraded really soon.

 

The case number is 29615687.

Message 13 of 24
Apprentice

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

To the Netgear support guy. If that is the case, then how come I was able to add both of my Arlo pro 2 cameras to SmartThings without any problems?

Just curious.
Message 14 of 24

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

I think it did work previously, but now doesn't. My guess would be if you remove them both from smart things and then try and re add them you will get the same thing. Uncheck from Arlo Connect then press save, then go back in and try and add them...if you dare....!

Message 15 of 24

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

I even tried adding it manually by going to th graph api and adding a new device and selecting Arlo Pro from the drop down list.

It adds something and you can see it in th Smartthings mobile app, but it’s impossible to turn it on.
Message 16 of 24

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

I don’t want to risk my first one either.
Message 17 of 24
Aspirant

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

Same issue here guys. I have two Pro 2s hooked up in ST but just added a 3rd and it fails with that error message. I’m going to open a ticket as well. Disappointing.
Message 18 of 24

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

I just spoke with support to confirm what we all already know... that the Arlo Pro 2 is not currently supported by Smartthings.  I think that if you got the Arlo Pro 2 to work in the past, it was more luck.

 

I also asked them about where to send the bug report and they told me to just post in the forums.... just like we are doing now so.... that means we just got to keep bringing up the issue until the Engineers decide to fix the bug!

 

Other then that, we just have to wait for the "Annoucement" which will come at some time in the future.

 

 

Message 19 of 24
Master

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

Disappointing. Glad I managed to get my 4x Pro 2 cameras connected to ST during the window where we could. Hopefully they'll sort it out soon for both you all and because I want to buy another add on camera

Message 20 of 24
Aspirant

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

I'm disappointed to learn about the current lack of integration with Smartthings but glad I came across this forum. I'm holding off on my purchase of an Arlo Pro 2 by NETGEAR 2 Camera Security System with Siren until it's confirmed that the system can integrate with Smartthings hub. 

Model: VMC4030P| Arlo Pro 2 Wire-Free Cameraarlo.netgear.com | Web Site/App
Message 21 of 24
brh Master
Master

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

I just read over on the Smartthings community forum that the problem with the Arlo Pro 2 integration with Smartthings has bee fixed and now seems tobe working.

 

Brian

Message 22 of 24

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

I just confirmed it is true. I was able to add my Arlo Pro 2 devices!
Message 23 of 24
Highlighted

Re: Arlo (Connect) in Smartthings fails when trying to add Arlo Pro 2 camera

Yep confirmed fixed 25/1/2018. Note that in the smartthings console the is reported as type "Arlo Pro Camera" once again, rather than "Arlo Pro 2 Camera" as it was reporting previously - so the fix seems to have been that someone has reverted the string which is reported back to Smartthings on registration.

Message 24 of 24