Arlo|Smart Home Security|Wireless HD Security Cameras

App version 2.7.2 for iOS

Reply
Discussion stats
  • 10 Replies
  • 617 Views
  • 0 Likes
  • 5 In Conversation
RChobby Virtuoso
Virtuoso
I see Arlo has released app version 2.7.2 for iOS. For those of you that have used it, how is the performance?
Dannybear Mentor
Mentor
No comment about performance but it has resolved two out of five of my issues.
I.e No errors when displaying snapshots and now plays the selected video from the library, so getting there I think.
This was checked on a iPhone 5s and iPad Air 2.
Admin using Basic plan.
RChobby Virtuoso
Virtuoso
Thanks for the update. What three remaining issues do you have?
Dannybear Mentor
Mentor
@RChobby,
Regarding the other issues, I have a crashing issue of the App when deleting multiple videos from the library while playing them, occurs after the tenth or thirteen delete. This has occurred since iOS App version 2.6.3. Both iPhone and iPad.
The other two issues I believe are base and camera firmware related, corruption of settings and recurring digital pixelation of video.
As far as performance using the latest App version, it has been working well with four cameras recording at the same time. Playbacks are smooth and not stalling. Loading of the App seems to have also improved.
jimmarshall87 Guide
Guide
Still has something which accessed the cloud on startup which blocks the UI until completed - can’t scroll or use live view until this has completed. Super annoying when you have an urgent need to access the camera, like say, oh, a security issue or crying baby. Can’t believe this is still broken after two updates. Sort it out Arlo.
Guru jguerdat Guru
Guru

It may help if you told us what was blocking use.

Dannybear Mentor
Mentor
I have noticed that the dashboard thumbnails sometimes do not immediately update as with the previous version of the iOS App. It can update immediately or I have to take the thumbnail out of screen focus to get it to update.
jimmarshall87 Guide
Guide
To clarify then, prior to 2.7.0 I could start the app and immediately use Live View or the tabs on the menu bar at the bottom of the screen. I have a mixture of arlo 2, arlo 2 pro and arlo baby cameras numbering 17 devices in total. I have two base stations. Since 2.7.0 and through 2.7.1 the app initiated some network requests to the arlo cloud which blocks the UI. This means that it is not possible to scroll the view, change tabs or press the live view buttons. The app is frozen. After about 10-15 seconds it becomes unfrozen and the UI becomes usable. My assumption is that whatever network calls these are were either not made or were made asynchronously previously. They are now made synchronously and block the UI. I would hazard a guess that this issue amplifies itself according to the number of devices that you have. Prior to 2.7.0 this did not occur and is a regression issue introduced in 2.7.0. 2.7.2 improved this slightly but is still making the app unusable. The issue is also worse on older devices - whatever processing is done following these network requests pummels the processor - the impact is less on my iPhone X compared to an old iPad I use for baby monitoring. The issue is significant enough when combined with numerous issues over the last few months that I am considering swapping out the whole system. I hope that now clarifies.
jimmarshall87 Guide
Guide

...and 2.7.4 released today - issue still persists.

jimmarshall87 Guide
Guide
And for the record, my issue above now fixed in 2.7.5
Diana6515 Guide
Guide

My iPhone PTT issue (where the sound would go out after hitting the PTT button) is now fixed. That was my only issue with Arlo Pro 2, and now it's working great.