Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Arlo Pro 2 and Setting Up Apple HomeKit

Reply
Discussion stats
doghousestudio
Guide
Guide

Arlo just "upgraded" my 2 base stations with the sole purpose of being able to connect/compatible with Apple HomeKit. They sent me 2 VMB4000's Refurbished (no box, packaging or manual) When following directions to set up HomeKit under My Devices > Base Station... HomeKit does not appear. I have restarted reset and confirmed firmware on base sation as well as  software on my AppleTV... nothing helps. I dont see any kind of Apple HokeKit code on the device itself and it didn't have any packaging so there is no way to scan a code that way. So frustrating and spent so much time on this... many many hours. It shouldnt be this difficult yet here I am. Please, any suggestions?

Thank you

 

Model: VMB4000 | Arlo Pro/Pro2 Base Station
1 ACCEPTED SOLUTION

Accepted Solutions
ShayneS
Arlo Moderator
Arlo Moderator

The fix for this issue has started rolling out. Please update your Arlo mobile app manually from the iOS store to version 3.5.1 and if you're still experiencing the issue, reach out to me in a private message with your e-mail address and I can send your system a HomeKit token reset.

 

Thank you 

View solution in original post

117 REPLIES 117
ShayneS
Arlo Moderator
Arlo Moderator

Hi @doghousestudio

 

Are you still experiencing this issue with adding your base to Homekit?

doghousestudio
Guide
Guide

YES

 

I emailed tech support at Arlo and got no response.

ShayneS
Arlo Moderator
Arlo Moderator

Are you receiving an uncertified accessory error within the Homekit app?

doghousestudio
Guide
Guide

No

 

I cant even get that far. I open the Homekit app and try to "Add Accessory" and it says either scan the code from the accessory or package or hold phone near accessory. It says if I'm having trouble enter the 8 digit code from device packaging... Arlo sent me the refurb base stations without any packaging. Can it really be this difficult? Is there not a code you can send me?

ShayneS
Arlo Moderator
Arlo Moderator

DId you happen to perform the steps in this article? How do I connect my Arlo camera to Apple HomeKit?

 

To setup an Arlo camera without a setup code:

  1. Launch the Arlo app on your Apple device.
  2. Tap Settings > My Devices.
  3. Select an Arlo base station.
  4. Tap HomeKit.
  5. Select the base station you want to add to HomeKit.
  6. Select a Home or tap Add New Home.
    If you don’t have a Home set up in the Arlo app, you are directed to create a Home.
  7. Select a Room or tap Add a New Room.
    If you don’t have a Room set up in the Arlo app, you are directed to create a Room.
  8. Tap Continue to add devices to HomeKit to add cameras or additional base stations.
  9. Continue through the setup flows to confirm the name and room placement for each device.
    Note: The name that you give each device is used for Siri commands. Choose a unique name that is easy to remember and pronounce.
  10. Confirm the name of the device.
  11. Tap Skip, or rename any other devices as needed.
  12. Tap Finish.
    Your devices are ready to use with HomeKit.
JiggyNole
Aspirant
Aspirant

Hi,

Just wanted to say that I have the Arlo Pro2 system (4 cmeras) and I was able to add the base station using the Arlo app and using the Home app. I do not have a HomeKit # on my basestation, so I know you can add it without a HomeKit number.

Jim

Model: VMB4000 | Arlo Pro/Pro2 Base Station
doghousestudio
Guide
Guide

@JiggyNole How did you do it? There isn’t a HomeKit discovered on my Base Station. It wants me to scan serial number (didn’t work) or Applekit logo on box (no box).

doghousestudio
Guide
Guide
Doesn’t work because no HomeKit shows up in the base station on the Arlo app. No where does it say HomeKit. Please advise
Model: VMB4000 | Arlo Pro/Pro2 Base Station
JiggyNole
Aspirant
Aspirant

doghousestudio,

 

I'm assuming you're on the correct fw version and you are connected on the same network as the Arlo devices. When following the steps to setup without a code, you first use the Arlo app and go to Settings > My Devices. I have inserted a screen capture of what my display looks like after doing that. You should see a column of data on the left and a column of data on the right. In the column on the left, further down you should see HomeKit AND  in the column on the right, down further, you will see another section with HomeKit. If you don't see both of these then I would say that you don't have the correct fw or the correct device. Check Shane's post about how to install without a HomeKit code. It does work!

 

What model is your Arlo base station?

What firmware version is it running?

 

Let's start there and see if we can figure this out.

Jim

 

 

IMG_3DA179EC5FB3-1.jpeg

JiggyNole
Aspirant
Aspirant

My basestation is a VMB4000r3

Firmware version is 1.16.2.3_3499_ccd29a0

 

Jim

 

doghousestudio
Guide
Guide

Thanks for your response. No, my base station page has everything your screenshot has EXCEPT the Homekit part. I attached a screen shot. Any ideas on what I can try now?

 

Base Station model VMB4000r3

Firmware 1.16.2.3_3499_ccd29a0

 

Thank you

 

 

JiggyNole
Aspirant
Aspirant

I've sent you a couple of Direct Messages but have not heard back from those, so guess we'll keep using this forum.

 

Let me know when you're available to work on this.

 

Jim

 

CoderNemesis
Tutor
Tutor

I have the same problem.  Bought the 3 camera system and was setting up Home Assistant and stumbled across this.  Did some digging and found that it detected the base station as a HomeKit device, but I don't have the menu option in the screenshot above for HomeKit.  Looked through my quickstart guide, no code, which is why i looked in the app, and no button.

 

Running Firmware v1.16.3.4_3614_c289687 w/ hardware VMB4000r3.  Was bought new from Amazon.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
ShayneS
Arlo Moderator
Arlo Moderator

Hi @CoderNemesis

 

When setting up your devices in the google home app, did you happen to follow the instructions provided here: Arlo Tech Support

CoderNemesis
Tutor
Tutor

That article does not support the hardware model I mentioned (VMB4000) I have and this is regarding integration via HomeKit, not Google Assistant.

 

Thanks

CoderNemesis
Tutor
Tutor

Don't know if this helps, but I'm also trying to set up HomeKit through the Android version of Arlo.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
ShayneS
Arlo Moderator
Arlo Moderator

Hi @CoderNemesis

 

Is the Homekit feature/button missing within Settings > My devices?

CoderNemesis
Tutor
Tutor

@ShayneS Yes it is missing.

ShayneS
Arlo Moderator
Arlo Moderator

Thanks for that info, Can you please provide a screenshot of this missing button by chance.

CoderNemesis
Tutor
Tutor
 

 

CoderNemesis
Tutor
Tutor

@ShayneS forgot to tag you on the last post so don't know if you saw the screenshot but it's in the previous post.

ShayneS
Arlo Moderator
Arlo Moderator

@CoderNemesis

 

Yes I received it, I am looking in to this for you. I will provide an update as soon as I can.

ShayneS
Arlo Moderator
Arlo Moderator

Hi @CoderNemesis

 

Do you have the latest Arlo app installed v2.22.5?

CoderNemesis
Tutor
Tutor

Yes, v2.22.5_28260