Arlo|Smart Home Security|Wireless HD Security Cameras

Can't Add Homekit on VMB4000r3 Q&A thread

Reply
nxc Apprentice
Apprentice
I got Arlo Support to send me a replacement (refurb) base station. I took it out, set it up, and it immediately connected to HomeKit on the first try. I know that doesn’t help anyone fix their current base station, but at least it seems like a new one can fix things. Now both of my base stations and all of my Arlo Pro cameras are in HomeKit.
stapi Star
Star
I have tried a factory reset after being assured by the arlo support that this will resolve the issue but still getting Uncertified Accessory error. Don’t waste your time...
Model: VMB4000 | Arlo Pro/Pro2 Base Station
stsui Guide
Guide
@nxc what’s the hardware version you got from them ? Is it VMB4000r3?
nxc Apprentice
Apprentice
Yep, it’s an r3 just like the old one. It’s running the same firmware, too.
KCDesert42 Guide
Guide

I did the same thing, no change.

cbrauckmiller Star
Star
Heh. My system is out of warranty. Not an option and I’ll be damned if I’m going to throw good money after bad.
nxc Apprentice
Apprentice

I don't know if it makes a difference, but I pay for Arlo Premier. Threaten to cancel and they'll take you seriously. They want your money over time.

stapi Star
Star

I've asked for a replacement to fix the Uncertified Accessory error and was refused as the problem is apparently known to the engineers and they are working on a software update to resolve.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Londan Aspirant
Aspirant

I have exactly same issue and have rebooted, reinstalled etc but still cant find any devices. This is really poor service on Arlo’s behalf. If this problem has now been around for months - can they not be bother to fix it?

Model: VMB4000 | Arlo Pro/Pro2 Base Station
JRios11 Star
Star
I try randomly doing the steps they suggest in hopes maybe it’ll randomly work but nope still nothing...idk why they have been dragging their feet considering it seems like a decent amount of people are having this issue...
Dbensette Luminary
Luminary
I have been told by support that they are requesting a new token for my device. If that doesn’t work, they are to send a replacement base station...

Fingers crossed something works
nxc Apprentice
Apprentice
I have a sneaking suspicion Arlo made a mistake and either lost or otherwise somehow allowed a bunch of the HomeKit setup codes to become corrupted/blacklisted. As ever, we don’t know, because they tell us so little. I’m happy my setup is now working but really aggravated it took a swap.
JRios11 Star
Star
This is annoying I figured I’d chat with them cause this has been going on for a while and no updates..no agents available and the allow you to call within 90days of purchase for free support but charge you after for calling the balls of this company such a disappointment in customer support that they have
stapi Star
Star

On Saturday I've got a message saying that my support case is being closed due to lack of feedback from me (!?!). I've got on the support chat and spent nearly 2 hours going through the reboots, app sing-outs etc.... because they've insisted this is required to resolve my issue even though all of it has been done before. Still getting uncertified accessory error. Now my case has apparently been escalated to the next level support but I am not going to hold my breath.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Geekynerd Aspirant
Aspirant

Tech support has been horrible with their oversea support to save a buck.  Still on call as I type which they had be reset the base and still no luck

JRios11 Star
Star
What I don’t understand is why not offer the HomeKit code for us to enter manually, like I was able to do with the ArloBaby camera I have...why only have us do it one way only which obviously hasn’t been working.
Nhott Guide
Guide
Prior to iOS 11 all certified homekit accessories had a hardware chip in them. This is/was part of the MFi program (Made for iPhone, iPad or iPod). Those devices have an authentication code and will be printed on a label somewhere. iOS 11 introduced a software based MFi ability. That was meant for devices that had already shipped but wanted to add homekit later. I don’t know the exact details but it’s some sort of encryption token verification. Arlo is using that method therefor no setup code.
nxc Apprentice
Apprentice

This is not technically accurate. Devices that have HomeKit support added after they shipped (so no HomeKit sticker) still do have setup codes. At one point I had a problem with some Belkin smart plugs where they'd added HomeKit support later, and I ended up in a situation where I couldn't re-pair them to another WiFi without that code. I eventually found a workaround, but the real solution was to use the app and save the HomeKit code assigned to each device, in case I ever need it again. Arlo, for whatever reason, is choosing not to show us the HomeKit codes.

JRios11 Star
Star
Curious if everyone with this issue running a beta version of IOS? Or it’s happening also to those on a standard version
Aec Star
Star
It happens in the latest build of iOS 13 too
Model: VMB4000 | Arlo Pro/Pro2 Base Station
Aec Star
Star
With iOS 11 onwards, Apple insisted every manufacturer standardize on the same chip as they used. The others felt the cost to comply was too high. This all the extra dongles and bridges to add back the same capabilities. If you can get them all to work together. It’s way less than 100% reliable for all platforms and devices.
Model: VMB4000 | Arlo Pro/Pro2 Base Station
stsui Guide
Guide
@Arlo, HomeKit Codes please.
Model: VMB4000 | Arlo Pro/Pro2 Base Station
cbrauckmiller Star
Star

It's clear that Arlo doesn't care about their customers.

 

I'll just use these things until they die and then move on to a REAL surveillance system.

Model: VMB4000 | Arlo Pro/Pro2 Base Station
john-john Aspirant
Aspirant

Hello Arlo.

 

I still see this issue being ignored, the first post i made about this issue is just being merged into the other countless threads about Homekit not working with Vmb4000R3?

When can we expect you to handle this problem?

This was an buying point for me and to see that you neglect it, is just miserable.

Please don't delete this post as future customers should see how you handle problems like this.

Best regards

 

john-john

Model: VMB4000 | Arlo Pro/Pro2 Base Station
JRios11 Star
Star
Yea they really don’t care I tweeted at the about the issue and emphasized not to reply with reviewing their “ work around fix” which doesn’t work and they obviously reply to try their work around haha total lack of Proper customer service