Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Keep getting this "Geofencing needs an internet connection..."

Reply
noscamiam Star
Star
My work around is to just arm and disarm the cameras using an Amazon Echo when leaving or arriving at home. I am not good about leaving the app always running in the background so I gave up geofencing. I met the enemy and I am him.
elfman Aspirant
Aspirant

According to Arlo's customer service center, this is a problem Netgear is having with the Arlo app and they are researching how to solve it. Has anyone else found a better solution?

Model: VMC4030| Arlo Pro Wire-Free Camera
RonnyD Initiate
Initiate
I have a Samsung phone & made the battery changes. That was straight forward. This removed those spurious wifi connectivity messages but has done nothing to fix geofencing. I can be within the defined radious and will still get alerts. Seems to ignore or not be aware of my location.
Model: VMC4030| Arlo Pro Wire-Free Camera
wing987 Tutor
Tutor

This is still a problem for me as well. Just today I tried to use geofencing again, only to have to put it back into my manually configured mode. Both phones were apparently not withing the large radius while we both were at hte front door, setting off that camera.

 

I have complained, and I have a support ticket STILL open with them.  Forget about a fix, netgear does not care. This problem would be fixed already if they did.

Luddy Apprentice
Apprentice

I just setup geofencing earlier this afternoon on my new Arlo Pro system and Samsung Galaxy S6 Edge on Verizon.  Same issues as everyone else.  Please fix this ASAP Netgear, come on.

Luddy Apprentice
Apprentice

Since I cant edit my post...happened again this morning.  It seems to me that the base line is offline or something else is wrong when this occurs.  My phoine has internet access off same WiFi so the WiFi is fine.  In the Arlo app, it shows the base station mode as "Getting status..."

 

Why is the base station having issues? 

 

P.S.  Setting airplane mode on phone and bvack to WiFi clears the Arlo alert about geofencing that will NOT go away otherwise.

Luddy Apprentice
Apprentice

I think I resolved this by using the geofencing off my Apple iPhone 6s.  Somethign is wrong witht he app on Android.  Android app constantly spits out error in topic and also app can't get base station status without taking forever if at all.

 

Fix Android app please.

micamote Guide
Guide

In order for the built-in geofencing feature to work, every phone that needs to be tracked has to have the Arlo app open and be logged in.  Since that's inconvenient and not very practical, I created a couple of IFTTT (If-This-Then-That) applets that don't require any open apps or logins.  They can be found on ifttt.com and are named "Arm Arlo when everyone in your Life360 circle leaves" and "Disarm Arlo when anyone in your Life360 circle arrives."  They've worked nicely for me and I hope they help anyone else who gives them a shot as well.

DukeofKent Aspirant
Aspirant
Not working for me either on Android. Frustrating.
Model: VMC4030| Arlo Pro Wire-Free Camera
RonnyD Initiate
Initiate
Solved the problem by downloading IFTTT on my Samsung and setting that up with a couple of very basic rules. Have tested this all week and works perfectly. The only thing I needed to do was adjust the exit/entry area. I'd recommend others take the same route if you need the problem fixed asap.
chrisp_ Aspirant
Aspirant

same issue here with iphones 6 & 7. Worked perfectly then all of a sudden getting this stupid message.

chwylam Initiate
Initiate

Please help fix this Netgear! its getting frustrating. I paid a lot of money for these and I feel like you aren't helping me any.

 

elfman Aspirant
Aspirant

None of the workarounds suggested to me from NetGear have been very helpful and I've opened two cases with them to try and figure it out.

chwylam Initiate
Initiate

it only gets worse, now my geofencing option on my phone disappeared. I mean vanished. I didn't do anything to remove it and poof its gone.

jschweda Tutor
Tutor
did you have a separate account for the second device? if you are logging in to arlo with the same credentials on both devices one will get kicked out causing geofencing to not work. I granted access to a second device and created it's own account and now geofencing works fine. I also had to turn off battery optimization for arlo.
wing987 Tutor
Tutor

Ok, I keep seeing people recommending stuff that anyone who has read this thread HAS ALREADY TRIED.  So, here is a quick summary for the common problems, this is not all inclusive and I am bound to miss something.

 

Problem: Keep getting this "Geofencing needs an internet connection..." with the additional problem of geofencing not reporting on the position of the phones correctly.

 

Verified facts:

*Users commonly have this issue on SAMSUNG/ANDROID devices

*Users with multiple people on the account each have a seperate account for each user, with permissions assigned approriately

*Users have sufficient data on the cell phone plan and are not being blocked or restricted

*Users have an up to date version of the AP

*Users have one or multiple tickets submitted to netgear, all of which have been placed on hold or an extended wait since the engineering problem is aware of the issue

*Users have disabled any and all battery or data optimization controls on their phones, allowing this app to bypass any of those options.

*Users will often (but not always) cease getting the connection error, but will continually fail at proper geofencing reporting.

*Users are aware that iphones tend to not have this problem, although some people have the complaint with iphone as well. Moreover, most have attempted fixes that DO NOT APPLY TO THE ANDROID! iPhone users get their problem resolved where android users never hear of a resolution, or even see an update to the app.

*Geofencing will report someone who is away, with the app open and with solid data (often even wifi) as at home, thus disabling setting used for away.  Or the reverse, a person at home will be reported as away, and if the alarm is set to on it will begin blaring.

*This appears to happen most often with people who have multiple people on the account, users with only themselves to worry about have the issue less frequently (but not entirely better).

*The app will accurately show that the phones are reporting in, showing the phone as away or at home. The problem is that the report itself is innaccurate, despite the phone itself having the correct GPS location being shown. (easy to test with google or other map based location services). So it gathers GPS data, but reports the position inaccurately.

*This may not be related, but often times the service is not accessible with the phone, stating it is disconnected. But another phone or computer, both on the local network and outside the local network, will access the system just fine (but the problem phone can access all other network based resources)

 

End result: An arlo camera system that has multiple modes and alarm setups that cannot effectively be used unless manually changed. So the "record less when home, and record more and sound alarm when gone" options are not worry free or automated as advertised, and must be manually changed each time. Occasionally geofencing will work, but the errors never fully resolve and thus the system cannot be trusted, and nobody wants an automated system to sound a screeching alarm when it should have been disabled when you got close to home, let alone fill up your data with pictures of you walking around the house that you never wanted to record (more important if you depend on the privacy....like enjoying your private space by walking naked in your house when the camera should never record you, after all...you are home and it should be set to "off").

 

This is still a decent system, however a huge portion of why most people bought it is broken for android users, and for the last year netgear has made ZERO improvements or attempts to change it, alienating their customers.  iPhone users however seem to get support more frequently.

dcbeargm Aspirant
Aspirant

On my Anroid phone, the problem started last month, and it comes and goes. I found the quickest way to clear the error is to use the App mgr. Manage the Arlo App - Click Arlo Notifications -  "Allow Notification" - Turn it off then turn it back on!

Model: VMC4030| Arlo Pro Wire-Free Camera
Wonderer Aspirant
Aspirant
I’ve been having the same issue for some time now. iPhone7 even with the new update..
Model: VMC3040 | Arlo-Q HD with Audio
ShawTeam Tutor
Tutor

Is it just me, or is Arlo getting flakier and flakier? The “needs an internet connection” comes and goes seemingly at random. Here for weeks, then gone for months.  I can be home and have been since the previous day and Arlo will tell me that I’ve just entered the Home Geofencing zone for no apparent reason. Or my wife and I will be out and several hours after we’ve left home it tells us we’ve left the geofencing zone. Or we come home together and one of us has entered the home zone and one of us hasn’t. Email notices used to be nearly instananeous, and now can take a long time to come in.

 

It is getting harder and harder to find it useful. It certainly was better when we first got it. 

 

Mike

brianzx7 Guide
Guide

I have stopped reccommending to anyone and have actually steered a few people away from this horrible device. It is clear that the engineers have either the skill or care to properly address this issue that is very widespread.

 

Unless there is a fix soon, I will start going to every forum I can find and tell everyone that their product is inferior and does not work.

 

Seriously bad press is on the horizon.....

Guru jguerdat Guru
Guru

I'm quite sure that Netgear is quaking in their boots.

brianzx7 Guide
Guide

I don't think they are quaking either, but I personally have directly steered 3 people away from purchasing their products and I am just one person.

havocnz Aspirant
Aspirant

Just made this change to my Samsung S7 Edge running Android 7.0 - fingers crossed, seems to have resolved.

buzzbeekeeper Aspirant
Aspirant

All, am new user to Arlo system. I have LG V30 Android Version  7.1.2. I just purchased this from Costco and upon setup last night I had software updates for the Base Station and the Cameras. I setup GeoFencing as well and this morning, Thanksgiving, went to grocery store for last minute items for Thanksgiving. I received the same "Geofencing message" i had to hunt thru android Battery/Power saving sub menus, in the Power saving exclusions, everything was turned OFF, I turned this on for the Arlo App. Will report back what the results are tomorrow, "Black Friday" Shopping Event! 

 

Also, scrolling to find this post, I saw mention of downloading and installing the IFTTT and work with in. Will update on Saturday.

Model: VMC4030| Arlo Pro Wire-Free Camera
Peppo57 Aspirant
Aspirant

Eivind wrote:

I did have the same problem, but have you tried turning off Battery Optimization. This is a feature of Android N / 7.0.

 

Android 7.1:

  1. Open up your Settings page
  2. Select: Device Maintanence
  3. Select: Battery
  4. Tap "Battery" next to the big circle and underneath the title Estimated Battery Life at the top of the page
  5. Drop-Down menu (upper right corner), select "Optimize Battery Usage"
  6. Drop-Down menu (under the "Optimize Battery Usage" title, select "All Apps"
  7. Find "Arlo" application, and set the switch in the off position

Hope that helps


I can confirm that it fixed my issue too 

Model: VMC4030| Arlo Pro Wire-Free Camera