Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Keep getting this "Geofencing needs an internet connection..."

Reply
cricenog
Guide
Guide
Found some battery settings here which I toggled and it seems to be improved :
Go to Settings -> Apps
Click the : Menu in top right, select -> [Special Access]
Select > Optimize Battery Usage ->
Click the dropdown menu towards the top of the screen that says: "Apps not optimized [v]" -> change to [All Apps]

Make sure Arlo is switched off, Not battery optimized
BrutalPan
Aspirant
Aspirant

I am receiving the same Geofencing error that everyone else is mentioning.  You cannot swipe the error away on either phone that we own.  A Galaxy s7 edge and S6 edge.  It is driving my wife bonkers and I cannot figure out how to correct this.  Please advise.

Model: VMC4030| Arlo Pro Wire-Free Camera
Dustin278
Apprentice
Apprentice

I just did what @cricenog siad to do and will keep you posted on if that fixes my problem or not - so far so goodSmiley Happy

Brooksben11
Aspirant
Aspirant

Same here; made the changes about 24 hours ago and haven't had an error since. Also noticed that the app seems more responsive overall, we'll see if my mind is just playing tricks or whether that's actually the case. I have however noticed that my phone's battery seems to have drained slightly quicker both yesterday and so far today. Nothing major, but definitely a few extra percentage points. Hopefully Netgear updates the app to fix this issue for good so I can turn battery optimization back on for the Arlo app.

houdini13
Aspirant
Aspirant

I was hoping the battery setting would make a difference...and it did seem to work perfectly for about 2 days but now it is back to constant home/away mode switching (20 times in the last 30 minutes).  Super annoying.  My battery seems to drain quicker as well.  

 

 

Dustin278
Apprentice
Apprentice

update: I have not had a problem for 5 days following the andriod fix posted..

Brooksben11
Aspirant
Aspirant

5 days problem-free for me as well!

Eivind
Initiate
Initiate

I did have the same problem, but have you tried turning off Battery Optimization. This is a feature of Android N / 7.0.

 

Android 7.1:

  1. Open up your Settings page
  2. Select: Device Maintanence
  3. Select: Battery
  4. Tap "Battery" next to the big circle and underneath the title Estimated Battery Life at the top of the page
  5. Drop-Down menu (upper right corner), select "Optimize Battery Usage"
  6. Drop-Down menu (under the "Optimize Battery Usage" title, select "All Apps"
  7. Find "Arlo" application, and set the switch in the off position

Hope that helps

Model: VMB3000 | Arlo Base Station, VMC3030 | Arlo Wire-Free Camera
astipe
Tutor
Tutor

Since I turned off battery optimization this issue has gone away for me.

tmorris9
Tutor
Tutor

I am the original poster. Unfortunatly in iOS there does not seem to be a battery saving feature to change. And I am still having the problem.

ShawTeam
Tutor
Tutor
Also on iOS, but it seems to have gone away in last week or so with no intervention on my part. But Instead I can be home for almost an hour before geofencing recognizes I am home and in the zone! Can't win!
jleonard84
Aspirant
Aspirant

I have been getting the same message ..."Geofencing needs an internet connection..." for two weeks now. Samsung S6, connection is fine. I receive this message on and off, doesn't matter if im on 4G LTE network, or Wifi, and I can't clear it unless I restart the phone. Solutions???

Model: VMC4030| Arlo Pro Wire-Free Camera
Dustin278
Apprentice
Apprentice
  1. Open up your Settings page
  2. Select: Device Maintanence
  3. Select: Battery
  4. Tap "Battery" next to the big circle and underneath the title Estimated Battery Life at the top of the page
  5. Drop-Down menu (upper right corner), select "Optimize Battery Usage"
  6. Drop-Down menu (under the "Optimize Battery Usage" title, select "All Apps"
  7. Find "Arlo" application, and set the switch in the off position

This is what worked for me on my Andriod S8

Wolfman73
Aspirant
Aspirant
Same issue for me also. Using S8+
fbishopjr
Aspirant
Aspirant

I have had the exact same issue.  Worked flawlessly for 1.5 yrs, over past week+ hasn't worked at all - constantly told it needs an internet connection when I clearly have one.  Apple IOS - Iphone.  

JoshFuller
Aspirant
Aspirant

having the same issue.  Weird thing is i have have had for about 5 days now and just started doing yesterday.  makes geofencing option and notifications worthless for me.  Hopefully they fix soon or i will be returning.

Wolfman73
Aspirant
Aspirant
Thx for great tip: after I followed this recommendation 3 days ago, everything is function 100pst again👍
Model: VMC4030| Arlo Pro Wire-Free Camera
wing987
Tutor
Tutor

Arlo geofencing has been working great since I applied this simple fix, but it took me talking to their support for weeks before someone recommended looking into it.

Simply put, Samsung shuts off some apps that run in the background when it deems it unnecissary, in a great attempt to save battery life. This is awesome and in most cases it works fine.

However, in the case of Arlo it shuts down data usage before it shuts off the app using the "Doze" or the "App Standby" features, which causes the app the suddenly become active since it is alerting you. So it never shuts Arlo down, only the data usage. And the alert keeps it off until you restart the phone, or when you open the app and get a good connection (which only removes the alert half of the time!).

The problem is that you can tell samsung NOT to use battery saver, and it still does to a small degree. And here is where we get the problems with Arlo, you think that it will continually run since you are not using a battery saving feature....but it will not.

Note: This fix will not stop prblems like ACTUALLY having no internet connection, only when it should be reporting and it is not.

You can go here: https://android.gadgethacks.com/how-to/android-basics-disable-doze-app-standby-for-individual-apps-0...
This is a great walk through, but it is a little out of date.

So, without the new photos, and on Samsung's home setup of Android version 7.0, follow these instructions:

1) Go to the settings, this is something you can adjust on the home screen so it is wherever you save it. If you deleted the icon, drag down the top of the screen, then drag it down a second time, in the upper right is the gear icon that takes you to settings.

2) Go to "Device Maintenance"

3) Click on "Battery"

4) To the right of the circle with your percentage in the middle, click on the "Battery Usage" button

5) In the upper right are the three dots, click on that and select "Optimize battery usage"

6) Where it says "App not optimized," click on it and select "All apps"

7) Scroll to Arlo, and turn it off

😎 Restart your phone

wing987
Tutor
Tutor

OOPS! My mistake! The last post is for Android!

noscamiam
Star
Star

The battery optimization fix worked for me as well.  I am using Android 7.0.  The directions as to how to find the power/battery setting varies depending on the device so do some hunting and disable battery optimization for the Arlo app.  It did the trick for me and apparently several others. 

bebop2k
Aspirant
Aspirant

I have a Galaxy S8 running android 7.0. Turning off the battery optimization for the Arlo app was the first thing I've done. And it did noting for the error. My phone is still getting the connection error message. Also you can't easily dismiss the error message without going through multiple steps. 

Model: VMC3030 | Arlo Wire-Free Camera
Thegametb
Aspirant
Aspirant
If you have the persistent notification (can't swipe away), you can force close the Arlo app and reopen it. It kills any active processes (like notifications). It'll save you having to restart your Android device.

How to force close varies from Android versions, you can either long press and get "App info" or go to Settings and find Arlo in the Applications/Apps section.. From there, you should see "force close" (beside Disable or Uninstall). Accept it and reopen the Arlo app. Usually when I get the notification, it tells me all my cameras are offline, so I have to kill the Arlo app to see them working as expected.

I'm using the Pixel XL and the Arlo app is super buggy for me. Some times the mode locks up and never moved off checking status or a mode freezes on save change. So I force close the app, reopen Arlo and it works fine again. Really annoying when setting up cameras, but oh well.
yeebee29
Star
Star
Has this issue been resolved? I keep getting this message as well as of recently.
Model: VMC4030| Arlo Pro Wire-Free Camera
JamesC
Community Manager
Community Manager

Engineering is currently investigating this issue. I will provide an update when I have more information.

 

Many users have had success resolving this issue by checking their mobile devices battery saving settings. Some devices have battery optimization settings that close or put apps to sleep after they have been idle for a period of time. Check your mobile devices settings and be sure that an exception is made for Arlo if you are running battery saving settings.

 

JamesC

wing987
Tutor
Tutor

Are you kidding me? The battery settings "fix" is only a bandaid fix for the alert and the alert only, the geofencing still does not work as it should when using multiple devices. The "engineering" team seems to be preoccupied, since an issue in programming like this should have been resolved within a week with even a single engineer dedicated to it. Simply put, netgear has no intention of actually fixing this yet and has made it obvious by ignoring the problem. The reasons for this could be many, but the lack of a fix being developed in over a year shows that it is not a priority to support their customers.