Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Geofencing not working since update

Reply
Snn5 Apprentice
Apprentice
It seems that if the app would stay open in background my geofencing issues would be solved. It's simple Android code and permissions. Other apps can run in background no problem. I do know that the app stays open and on top of the main screen the cameras will continue to operate. And that might be an issue if you are on Arlo standard cameras that use batteries. However it should be possible to stop the live feeds with the app open in the background and only run live feeds when it is on top of other apps on the main screen.
LiCi Apprentice
Apprentice

YEP exact same issue after iOS update of the app to version 2.4.7. No longer recognising when we are away or back home. If device is showing out of zone then it will stay out of zone even if we arrived back home and vice versa.

 

The app does not seems to be running in the background. If I open the app, minimise it, wait few mins and open it again, it went back to beginning where it will try to log me in from start.

 

Netgear are you listening, fix your freaking app. and Yes I have done all the "disable/enable" devices steps and have even gone as far as reset to factory default and resync all my cameras and resetup GeoFencing.

vk2gho Tutor
Tutor

After 48 mins and 16 seconds of waiting, I finally got to speak to a ‘technical’ person who was very helpful but unable to fix the geofencing problem (which wasn”t a problem until a week ago).

I made it clear that he needs to send this problem up the line and fix this issue or I will be returning my 3 month old Arlo system as it no longer meets the manufacturers claims.

Here is the email follow up recommendations from my technical call, which I have followed with no success:

 

 

Here are the workaround that you may try to fix the issue on your geofencing.

1. Phone name should not contain any special characters under Geofencing's enabled devices.
iPhone=( Phone settings > General > about )
Android = Phone settings > About Device
2. After changing the phone name under the phone's settings, make sure that you powercycle the phone so that the change name will be applied.
3. Make sure that location services is enabled for the phone, and is always available for the Arlo App
iPhone= ( Settings > Privacy > Arlo )
Android= ( Settings> Location Services)
4. Now, devices should now show up under the Enabled devices page under Geofencing, but these devices may show "Unavailable".
5. To fix this, uncheck all devices > Done > Save.
6. No device should be enabled for geofencing now.
7. Check all devices again > Done > Save.
8. Devices should show the correct status and Geofencing should be working.

We appreciate the time assisting you. Thank you for choosing NETGEAR.

Regards,

XXxx
Expert ID: xxxxx 
NETGEAR Support Expert

 

Model: VMC4030| Arlo Pro Wire-Free Camera
Cronqvist Guide
Guide
It seems the app is not able to run I background. Every time the app has been idle for a while I need to login.
LiCi Apprentice
Apprentice

Yes, same issue with IOS also. run the app and few mins later try to open the app, it goes back to login screen and ask for login again.

 

GeoFencing needs the app to be running in background to be able to works which is not the case after the latest update.

 

FIX IT!!!!!

Bjelken3 Aspirant
Aspirant

I´ve got exactly the same problem since last update:( Worked just fine before.. please fix this!

Highlighted
MissMisery Aspirant
Aspirant

I've also had the same problem the last few weeks.

Model: VMC4030| Arlo Pro Wire-Free Camera
RChobby Virtuoso
Virtuoso
Please let me know when you find geofencing works again. I’m using iftt while it is broken, but when it worked the Arlo application was preferable.
Sparky4460 Star
Star

Thanks for the good discussion on this issue.  Especially for the effort vk2gho made contacting technical support.  I have also tried all those fixes and nothing helped.  Looking at information in the app it is apparent to me that the app knows if the phone is "in zone" or "out of zone" but for what ever reason it is not automatically switching modes.  That being said as I mentioned it did work for me yesterday.  I can also force the switch by going into the app and selecting a different mode then switching back to Geofencing mode.  Once you do that the app will select the proper mode.  It is clear something is either wrong with the app or a change Apple made to iOS.

 

For me this started getting intermittent several months ago.  I noticed it might take an hour or more before the app realized I was out of zone.  Within the last few weeks it stopped work completely except for yesterday.

 

Hopefully Arlo will respond.

Model: VMB3000 | Arlo Base Station
DaveWoj Virtuoso
Virtuoso

Mine also does not kick in until the app is opened.

I have noticed this for a few months now.

Cronqvist Guide
Guide
This is what's wrong. See attached screenshot. Can't believe this should be so hard to fix.
Snn5 Apprentice
Apprentice
Thread should be named "GeoFencing not working with.....Anything."
1VFR Guide
Guide

A response from Netgear would be nice.

For example: We are working on it. 

Everyones phone is not compatiable with our product...

I could go on for days.

Guru jguerdat Guru
Guru

I don't use GF but that implies that the app is sleeping. I hope you've tried the battery optimization changes but, unfortunately, if that doesn't help, I suppose that's not the real answer.

swinokur Aspirant
Aspirant

Same problem. App says you have left or entered home area, but does not actuall arm or disarm the camera . worked once. never again.

 

Netgear fix this issue, Supoport is the group who told me about geofencing but it does not work.

Model: VMC3040 | Arlo-Q HD with Audio
swinokur Aspirant
Aspirant

The app found my phone name even with an apostrophe. i removed it and will test to see if it works. i will focre quit thecapp and restart it

Sparky4460 Star
Star

For the second day in a row the geofencing is working.  I don't know why but I am hoping Arlo made some changes to fix the problem.  My phone is a iPhone 7 Plus so I do not believe it has the battery optimization features.  And I do not believe the app is sleeping.  I know the phone is not.

Model: VMB3000 | Arlo Base Station
JamesC Community Manager
Community Manager

Engineering is currently aware of and investigating an issue with Geofencing that is affecting some users. I will provide an update as soon as I have more information.

 

JamesC

JamesC Community Manager
Community Manager

Engineering is currently aware of and investigating an issue with Geofencing that is affecting some users. I will provide an update as soon as I have more information.

 

JamesC

ilioni Star
Star

Hi JamesC,

 

Your statement about GeoFencing affecting some users is an understatement! It is affecting both iPhone users and Andriod (Samsung) users. Bear in mind that iPhone used to work flawlessly but someone broke it recently! 

RChobby Virtuoso
Virtuoso
Thanks, Sparky! I’ll turn mine on again and report back.
edif30 Aspirant
Aspirant

Can you be more specific of what users/devices/etc?

Tbrainz Tutor
Tutor
+1 - broken geofencing again....
Model: VMC4030P| Arlo Pro 2 Wire-Free Cameraarlo.netgear.com | Web Site/App
ilioni Star
Star

Hi edif30,

 

If you are from the Arlo App development team, have you tested the app and are you saying that you are not able to simulate the problem in your environment? This happens to not just one user but multiple users and it is not specific to one platform. I have a iphone 8 with the latest IOS code which was working until recently. My wife has a samsung S8+ and both of them are not working (for the geofencing). The status doesn't update the status regardless of the mobile leaves the security perimeter or enters the security zone that is defined in the geofencing setting. I am away/out from my house and it is showing that I am in zone while my wife is at home but arlo geofencing app is saying that she is out of zone. This is getting ridiculous!

JamesC Community Manager
Community Manager

Engineering is currently aware of and investigating an issue with Geofencing that is affecting some users. I will provide an update as soon as I have more information.

 

JamesC