Arlo|Smart Home Security|Wireless HD Security Cameras
× Arlo End of Life Policy Notice
To view Arlo’s new End of Life Policy, click here.

Camera is recording Pink, Already returned once, now doing again Need link to return

Reply
Discussion stats
  • 2 Replies
  • 3269 Views
  • 0 Likes
  • 3 In Conversation
thecoooch
Star
Star

As most of you know getting Arlo support is like finding a needle in a haystack.  Please help.  I already had this issue with this camera, went through the reams of paperwork for an old "RA process".  This took a few weeks.  Need to do this again, although I am now past one year from original purchase but less than 4 months since the faulty camera was replaced (and is now broken again).   Does anyone have the link or email to initiate a return? 

2 REPLIES 2
EricSacto
Aspirant
Aspirant

I have the "Arlo" system. And I've had the problem of one of my camera's recording things in 'pink'. I've read through some of these posts here, and tried some of what I've read. I did some of what I've read, with one of my problems, and it worked! One of my camera's was recording in pink... I opened the battery cover, vigorously tapped on all sides of the the camera, put it back in service, and it fixed the problem... the pink went away, the camera now works properly, without the pink color. I'm still having problems with false detections, but I'm still learning. I wish Neatgear gave better instructions.

jguerdat
Guru Guru
Guru

Contact Support link at the bottom of the desktop version of these pages.


thecoooch wrote:

As most of you know getting Arlo support is like finding a needle in a haystack.  Please help.  I already had this issue with this camera, went through the reams of paperwork for an old "RA process".  This took a few weeks.  Need to do this again, although I am now past one year from original purchase but less than 4 months since the faulty camera was replaced (and is now broken again).   Does anyone have the link or email to initiate a return?