Arlo|Smart Home Security|Wireless HD Security Cameras

Arlo Ultra 4K - camear connection issue.

Reply
Discussion stats
  • 5 Replies
  • 1230 Views
  • 0 Likes
  • 4 In Conversation
TommB
Aspirant
Aspirant

I picked up my Ultra 4K on 24th, set it all up. Done all the firmware updates. One of the cameras have struggle to connect. When connected to the hub, it will take a very long time to connect (if connected at all) via app and to view the video from the camera and the connection will not last long, ie. it will lost its connection not long after. While connected it also have a loud static noise.

  • I reset the system (with reset button) and went through all the initial set up again a few times without any difference
  • Swapped batteries (as if that would have any effect on the issue) - no affect!
  • Swapped cameras location - no difference
  • Removed batteries from the other two (working) cameras so only this one is powered just in case the other two were interfering - no there weren't !
  • Moved the camera around the room, even have it 1 - 2 feet from the hub

Having done all this I took the unit back to the store for an exchange. They said they will have to send it back to Arlo for it to be checked! This is after less than 24 hours of purchase and they refused even to provide me with another unit! To me this is a DOA camera.

 

p.s the tech guy at the shop put the fault down as poor image quality! WTF obviously didn't hear a word I said.

5 REPLIES 5
SAM21
Apprentice
Apprentice
Sorry to hear about your issues. Some these cameras work without having issues and sometimes they just don’t. It’s the Arlo way. I am happy that you were able to return them. Unfortunately for me I am stuck with my sometime it works and sometimes it doesn’t.
TommB
Aspirant
Aspirant

Hi Sam, it is so stupid that a company could have released something like this to consumers - have they really or even test their product before they put them out for sale?

I still don't know if I will get any result after this, the store indicated they can not rely on my word, if they find that the unit is not faulty then I will be like you where I'll be stuck with it too. 😞

 

Bunch of criminals. Sorry I am very bitter because this is a lot of investment for me.

 

Tom

LINKx12
Aspirant
Aspirant
I've also purchased the 2 camera 4k pack, side by side one camera works flawless the other struggles on connection and drops offline and doesnt send notifications. If I cant get it to work soon ill post for return. First expierience with arlo and not too happy so far.
StephenB
Guru Guru
Guru

@LINKx12 wrote:
I've also purchased the 2 camera 4k pack, side by side one camera works flawless the other struggles on connection and drops offline and doesnt send notifications. 

I suggest exchanging the system with the seller.  The other option is to contact support and get a warranty replacement. https://www.arlo.com/en-us/support/contact.aspx

TommB
Aspirant
Aspirant

I took the unit to the seller but they refused to listen (of course - customer doesn't know what they're talking about). They said they will test it and see if I was telling the truth.

Next day, they contacted me and said I could now have my refund or get a new unit. No apology . . .

Money back is it - don't want to deal with this seller.

Discussion stats
  • 5 Replies
  • 1231 Views
  • 0 Likes
  • 4 In Conversation