Arlo|Smart Home Security|Wireless HD Security Cameras

Fail to connect Q/defective product. Went back to Best Buy and exchanged it and now it works.

Reply
Discussion stats
  • 2 Replies
  • 467 Views
  • 0 Likes
  • 2 In Conversation
Gds-5486
Aspirant
Aspirant

Bought a Q and tried about 15x to install. The instructions are simple. Went all through the steps with no issues until 'looking for camera' and it would time out, buzz and go back to orange led. I reset between each attempt.

Called Arlo customer service; worthless, impatient and unable to understand the heavy Asian accent.

Looked up Arlo Community, some people found defective cameras.

I went back to Best Buy and talk to a tech, said possibly defective and exchanged the Q.

I took it home and it connected first time and is working as it should.

I emailed Arlo customer service with service case number and told them the results, a defective camera and they could close out the service number. They are still inquiring me of the results of my case, one hand doesn't know what the other is doing.

The camera works great but Arlo needs to quit being so cheap and get some competent customer/tech help.

Model: VMC3040 | Arlo-Q HD with Audio

Accepted Solutions
Gds-5486
Aspirant
Aspirant

Q was defective, exchanged and working.

View solution in original post


All Replies
JessicaP
Arlo Moderator
Arlo Moderator

Hi Gds-5486,

 

Thanks for sharing your experience with the Arlo Q camera and I'm glad your new Arlo Q is working for you now.

 

Feel free to let me know your case info and I can let the support team know that you've resolved your problem and to close your case.

Gds-5486
Aspirant
Aspirant

Q was defective, exchanged and working.

View solution in original post