Arlo|Smart Home Security|Wireless HD Security Cameras

replacement battery that worked for one charge cycle

Reply
Discussion stats
  • 6 Replies
  • 531 Views
  • 0 Likes
  • 6 In Conversation
Josh99 Follower
Follower

I have a replacement battery that worked for one charge cycle. I contacted support via chat. They said they would replace it. Then the email confirmation offered a camera swap. I don't need a camera. I emailed several times trying to clear that up. I have Christine A, Expert ID 46533 on chat now, being outright rude about it and saying, "We are unable to send again since we are done with it." Refusing to get a supervisor. I'm 20th on hold on the phone. This support is worse than Comcast. Anyone know how to get support here?

JessicaP Arlo Moderator
Arlo Moderator

Hey @Josh99,

 

I have sent you a PM (private message) to gather more information from you regarding your experience with the support team.

Jasper_L Aspirant
Aspirant

I got the same person and **bleep**test support experience ever. Try to record my credit card detail for 20 minutes and never get it right. I have requested a call back from different agent, and it NEVER happen. What a joke. 

DeviantCelt Star
Star

I think they're known for this. At least that's what I've seen from other customer complaints the past year or so. 

lakersfreak Apprentice
Apprentice

I've been in touch with support for about 6 weeks now regarding multiple issues I've had with the cameras. Some of the issues were just resolved autmatically through updates, but one very annoying issue still remains. I get 6 alerts for every motion notification. I have talked, emailed, and chatted with support several times, and I always get the response of "we need to escalate this to engineering and will get back to you within 3 days". It's been over two weeks and no one has responded. Either they really don't care, or their engineering team has no idea how to fix this very annoying issue. 

DeviantCelt Star
Star

It's both. 

pc2k17 Hero
Hero

Fixes for multiple notifications have been posted here many times.

 

For android, clear your app cache. If that doesn't help, uninstall, delete all google, samsung, etc backups, reboot phone, reinstall arlo app, set your notification sound.