Arlo|Smart Home Security|Wireless HD Security Cameras

New arlo app unable to login Error 2605

Reply
Discussion stats
Brett73
Guide
Guide

So I have dowloaded the new Arlo App from the AppStore and also deleted the Legacy app from my phone.

 

I have signed into the new Arlo App but its not showing any of my cameras and just shows the text "Log Back In" or "Log Out" at the bototom of the screen.

 

Anyone else have this problem or am I doing something wrong ?

Model: VMC3030 | Arlo Wire-Free Camera
1 ACCEPTED SOLUTION

Accepted Solutions
JamesC
Community Manager
Community Manager

A cloud fix was released on 10/02/2019 that resolves an issue causing some users to receive error 2605 when attempting to log in to the Arlo Mobile App. Please let us know if you continue seeing error 2605 when attempting to log in.

 

Thank you,

JamesC

View solution in original post

68 REPLIES 68
ShayneS
Arlo Moderator
Arlo Moderator

Hi @Brett73

 

Are you still experiencing this issue? Have you tried to delete & re-install the Arlo app?

Brett73
Guide
Guide
I have deleted the app twice and downloaded again and it still giving the same problem. I have reverted to the legacy app in the meantime and that works fine. Hope it gets sorted before the switch date
ShayneS
Arlo Moderator
Arlo Moderator

Which Phone/Device/Model/OS are you experiencing this issue with? I am not able to replicate this issue.

Brett73
Guide
Guide
IPhone 7 with IOS 12.4
ShayneS
Arlo Moderator
Arlo Moderator

@Brett73

 

By what I understand so far, you can not login (at all) with the new Arlo app?

Kmjones
Aspirant
Aspirant

I can’ Get the new app to work at all. Does not convert does not sync does not do anything. I did delete and put back on. Still nothing 

Model: VMB4500 | Arlo Pro/Pro2 Base Station
ShayneS
Arlo Moderator
Arlo Moderator

Hi @Kmjones

 

  Have you tried contacting customer support regarding this issue? I have attached the link here for you - Arlo Tech Support

Dbuscaino
Initiate
Initiate
I’m experiencing exactly the same problem using iPhone X, version 12.4.1
Brett73
Guide
Guide

I thought this was a support page for Arlo ???

 

I have downloaded the new app again today and it's still not showing me my cameras at all, plus it also shows a new error at the top of the screen 2605 : Optional ("We are sorry, The system is expericning an unexpected issue.")

StephenB
Guru Guru
Guru

@Brett73 wrote:

I thought this was a support page for Arlo ???

 


Not really, though there is a link on the support page.  This is a community forum.  Users help one another (along with Arlo mods).   

 

While we can resolve a lot of problems in this forum, support is contacted here:   https://www.arlo.com/en-us/support/contact.aspx 

HeatherF
Aspirant
Aspirant
I am having the same problem on iPhone XR. Unable to login with correct credentials. All I get is a “log back in” message or logout option. Please fix!
ShayneS
Arlo Moderator
Arlo Moderator

Hello,

 

Which version of iOS & the Arlo mobile app are you using?

 

Can you download iOS 13 & update to the new Arlo app ver. 2.9 & test again.

OozyPayload
Initiate
Initiate
Previous Arlo app on my IPhone XS IOS 13 had no problems prior to installing this “new” Arlo app! Now, I don’t get push notifications, sensitivity is different...multiple recordings every 5-10 mins even turning down sensitivity from previous app. Checked all push notifications thru app and iOS settings, rebooted phone & deleted “new” Arlo app, reinstalled with no change!?!? Frustrating for all of us!
Model: VMC4030 | Arlo Pro Wire-Free Camera
StephenB
Guru Guru
Guru

Have you checked the app store for an update?

 

The New 2.8 app was updated to 2.9, and people are saying it works with iOS 13.

 

BTW, iOS 13 itself will be updated to 13.1 on 24 September (and iPadOS is launching then too)  Not sure why Apple bothered releasing iOS 13.

HeatherF
Aspirant
Aspirant
I am at iOS 12.4.1 and using the Arlo 12.9 arlo app.
HeatherF
Aspirant
Aspirant
I mean 2.9 arlo version.
Weasels-23
Aspirant
Aspirant
Same problem Ipone8
Atomskier
Aspirant
Aspirant
Mine is doing the same thing
Danton
Aspirant
Aspirant

When I switch to then new Arlo app I just get a login page. Login seems to succeed, but returns again to the Login page.

Using the Arlo Legacy app or a browser I can successfully log in and see my device. I have reset the base station added the camera new, but nothing seems to change. So if the Legacy app stops working on Sep-3th, my device is obsolete....?

 

Android 5.02 on a Wiko Ridge 4G, the problem is with Arlo App 2.9.0_25890

Model: VMC3030 | Arlo Wire-Free Camera
jguerdat
Guru Guru
Guru

Start by rebooting the phone and reinstalling the app.

Danton
Aspirant
Aspirant

Uninstalling, removing the legacy app, rebooting and new install does not change anything. Still just getting the login page.

jferriss
Aspirant
Aspirant
My camera do not show up on new Arlo app
jferriss
Aspirant
Aspirant
I am also
dolphy
Initiate
Initiate

I have the same problem... but there was also a yellow message at the top "2605 Optional ('We are sorry.  The system is experiencing an unexpected issue.").  Not a single time i can use this app.