Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Can't Log In To ARLO On PC

Reply
Discussion stats
pc2k17 Hero
Hero

Ok, I didn't know it wasn't available in chrome 71. I don't use chrome as my main browser, but have it installed. Was on version 70, so updated to latest version 71.

 

Go to the Arlo website, log in, chrome tells me there is a newer version of flash available click here, I click, chrome asks me to allow or block flash, I choose allow, chrome now refreshes the web page since flash settings were changed, which logs you out of the Arlo site, which it should, normal behaivor. I log back in and everything is working fine in chrome. Win7 and Win10. Also Edge works fine on the Arlo website as well, maybe anyone having issues with chrome should try Edge in the mean time. Not sure what the issue is but its all working for me.

Highlighted
skisnkeys Guide
Guide
Thanks for that. Three browsers on the Mac, I am out of options. Maybe I'll try Opera. LOL.
Guru jguerdat Guru
Guru

@pc2k17 wrote:

Go to the Arlo website, log in, chrome tells me there is a newer version of flash available click here, I click, chrome asks me to allow or block flash, I choose allow, chrome now refreshes the web page since flash settings were changed, which logs you out of the Arlo site, which it should, normal behaivor. I log back in and everything is working fine in chrome. Win7 and Win10. Also Edge works fine on the Arlo website as well, maybe anyone having issues with chrome should try Edge in the mean time. Not sure what the issue is but its all working for me.


Huh. I never would have thought to click on the "click here" since I figgered it would take me to Adobe which isn't needed for Chrome or Edge. Now that you pointed me there, I find it works fine for both Chrome and Edge. Who'da thunk it?

 

Thanks.

pc2k17 Hero
Hero

@jguerdat

Ya it's a misleading message, I just knew from experience because Edge does the same thing. Some sites say it needs a newer version of flash, but since it's "built in" to the browsers now, it really just needs you to allow it. The message should be about allowing not upgrading. I'm not sure if it's a website issue or browser "feature".

Jamesfiro Aspirant
Aspirant

This solution did not work for me. What did work was:

Chrome/Settings/Ctrl/F search for Flash/Content Settings/Block sites from running flash/Allow/ https://arlo.netgear.com

Done. I hope that helps someone. 

Guru jguerdat Guru
Guru

That works on older versions of Chrome but not newer. WHat version are you using and on what OS?

Jamesfiro Aspirant
Aspirant

Win 10 and as I was checking to see which Chrome version I had, it updated and no longer works. Therefore, back to the drawing board. I am back to square one of it not working. Oh well. I will keep checking for a solution here. Thanks. 

Guru jguerdat Guru
Guru

I'm on W10 and the latest Chrome (v71). It works fine once you click on the "click here" in the Flash banner at the top. Accept the pop-up.

Jamesfiro Aspirant
Aspirant

Mine was working flawlessley for about 5 minutes until Chrome updated to 71.0.3578.80 (Official Build) (64-bit) on my Win10. Now Chrome will not work at all for Arlo even after clicking here. I need to use Edge or Firefox. 

pipsf Guide
Guide

I've updated to the latest version of Chrome and it still works for me. I'm on a Mac though.

 

FWIW, Microsoft announced Edge will be migrating to Chromium soon -- that means it will be using Chrome's engine to render pages and will essentially have the same compatibility pros/cons as Chrome.

Jamesfiro Aspirant
Aspirant

After making changes to Chrome settings and updating to latest version, Chrome stopped working even after clicking OK to latest version lingo. I uninstalled Chrome and Flash completed, reinstalled both and now I am happy to being able to click OK to latest each time. For now, I guess thats the best Arlo can do. 

Confluence13 Aspirant
Aspirant

@jguerdat

 

I cannot login to my account on my PC using Chrome (current).  I read the entire thread.  When I try and login I see 'plugin blocked' on the browser bar.  I have "allowed" flash, still get the same message each time.  

pc2k17 Hero
Hero

@Confluence13

 

Click on the flash blocked icon, choose manage, under Allow add: https://arlo.netgear.com:443 and also add https://arlo.netgear.com. Close browser and try again. If you still see the blocked again, ignore it, mine always says it too, but everything works fine.

JoeCymru Virtuoso
Virtuoso

If you log out of Chrome, you will need to give flash permission again when you open any flash content site even if you allowed it before, including Arlo, if you have Chrome build 71.

Guru jguerdat Guru
Guru

@Confluence13 wrote:

I cannot login to my account on my PC using Chrome (current).  I read the entire thread.  When I try and login I see 'plugin blocked' on the browser bar.  I have "allowed" flash, still get the same message each time.  


Maybe a random question but are you using Kaspersky anti-virus?

schumaku Master
Master

@Jamesfiro wrote:

After making changes to Chrome settings and updating to latest version, Chrome stopped working even after clicking OK to latest version lingo. 


There is a "f" item showing up in the Chrome URL field, you have to click on it and mark "Run Flash this time."

Chrome 71 72 73 - Flash was blocked.PNG

This seems to be the "standard" for the current Chrome 71, the next Chrome 72 (as per the Beta), and very likely Chrome 73 (Chrome Canary build).

 

@Jamesfiro wrote:

I uninstalled Chrome and Flash completed, reinstalled both and now I am happy to being able to click OK to latest each time.  

If you are only using Chrome, there is no need to install Flash - Chrome has a built-in Flash version.

 

@Jamesfiro wrote:

For now, I guess thats the best Arlo can do. 

No, I can't agree. It should not be difficult to check the browser type and version and issue a more informative pop-up on the top notification bar than a misleading update hint.

 


---
Please click on thumbs up if this answer was useful - thank you!
Bigherd Aspirant
Aspirant
Same issue with Opera.
Guru jguerdat Guru
Guru

Not an Opera user but what have you tried? What do you see? Have you allowed Flash to run? Can you set arlo.netgear.com as an allowed site? Do you get a newer version of Flash message and tried clicking on the "click here" link if it's displayed?

Bigherd Aspirant
Aspirant

I had to go to my anti virus software set the following as trusted websites.  Now everything works great!!  

 

01.JPG

 

 

Attatood Aspirant
Aspirant

Edge WAS fine, but now having issues with it as well. NETGEAR needs to re-write and GET AWAY from flash like everyone else is doing!!

Guru jguerdat Guru
Guru

Flash has nothing to do with lgging in, just with live view and pan and zoom in camera settings. Something else is going on. What have you tried? What do you see? Wat anti-virus are you using?

Attatood Aspirant
Aspirant

I humbly appologize. I added Arlo as trusted in Kaspersky and I am able to login, although it still tells me I need to update Flash. I still stand firm that Netgear needs to get away from Flash. This system costs way too much to be having ANY kind of issues.

Guru jguerdat Guru
Guru

I totally agree that the Flash requirement needed to go away a long time ago. Click on the "click here" link in the Flash warning banner to allow Flash to run which will continue to work as long as you don't close the browser.

JerryR Luminary
Luminary

Absolutely. Every day I have to click the "click here" to get rid of the Flash message.

Dg_in_FL Tutor
Tutor

Unfortunately, this solution no longer works with the latest version of Chrome, which does not have chrome://flags/#enable-ephemeral-flash-permission. 

 

Arlo/Netgear needs to offer an updated solution ASAP.