Arlo|Smart Home Security|Wireless HD Security Cameras

Arlo Pro - Cannot add 2nd device to geofencing - Android phone

Reply
Discussion stats
  • 15 Replies
  • 1528 Views
  • 1 Like
  • 7 In Conversation
Rowben
Aspirant
Aspirant

I recently set up geofencing on my phone.  Android Huawei P20 Pro.  I tried to add my wife to the geofencing rule (i can see her phone on the list but it's greyed out) and when I try to click to select her I keep getting the message saying:

 

"CANNOT ENABLE DEVICE.  Location services are not permitted on this device.  To enable Geofencing for this device, go to settings > privacy > location services and select "allow".

 

My wife has the exact same phone as me and has all permissions allowed, just as myself..  Anyone got any pointers to get this working?

Model: VMB4000 | Arlo Pro/Pro2 Base Station, VMC4030 | Arlo Pro Wire-Free Camera
15 REPLIES 15
JessicaP
Arlo Moderator
Arlo Moderator

Hi Rowben,

 

What device is your wife using? Has she tried disabling the location services and allowing it again to see if that helps? If so, have her reinstall the Arlo app and reboot her phone device to see if that helps.

Rowben
Aspirant
Aspirant

Hello, she is using the exact same phone as mine - Android Huawei P20 Pro.  

JessicaP
Arlo Moderator
Arlo Moderator

Try to remove her grant access and re-invite her again. Then have her log out, uninstall the Arlo app, reboot her Huawei phone, reinstall the app again and log back in.

JesseInMontana
Aspirant
Aspirant

I'm having the same problem. I can't add my wife's phone to geofencing as I'm getting the same message. All the permissions for Arlo are turned on in her phone. Arlo isn't recognizing it though. We both have the new Samsung S-20 Ultra phones. I've removed her, re-added her, uninstalled and reinstalled the Arlo app on both our phones, nothing seems to work.

JessicaP
Arlo Moderator
Arlo Moderator

Hey JesseinMontana,

 

Have you tried disabling the location services on her device, rebooting the device, and re-enabling it to see if that helps? Is this happening when you're on WiFi and/or cellular data?

TimKaas
Aspirant
Aspirant

I am trying to use geofencing combined with planning so when me AND/OR my wife's phone are not at home, the base station will be enabled, but only when we are both not at home (and in the evening and night) the camera should be enabled.

It works with my phone, but my wife's phone is "not available" in the app. she has her location switched on, and I checked the application permissions, and location was set enabled for Arlo app.
also my wife got the message "do you want to join the geofencing" and she pressed "yes" but still in both our apps (connected to 1 account of course) her phone still is "not available" in the geofencing settings (the phone is in the menu, but grayed out it says "unavailable"

I hope you can help me, cause I am so close solving this issue, but still I can't

Model: VMB4000 | Arlo Pro/Pro2 Base Station
ShayneS
Arlo Moderator
Arlo Moderator

Hi @TimKaas

 

What version of the Arlo app are you using on the phone(s) & what version OS are the phones running.

TimKaas
Aspirant
Aspirant
We both have the latest version of the arlo app 2.13.1_27040

And my wife (where it doesnt work) has android 7.1.1
ShayneS
Arlo Moderator
Arlo Moderator

What phone is your wife using, have you tried to update to the latest version of Android?

TimKaas
Aspirant
Aspirant
She is using a samsung J5 (2016 version) there is no newer version of android available for that phone.

But why would the arlo app not work on this android version, the phone is visable in the geofencing menu.
Is geofencing only working from a specific android version and above ?
qlin3
Tutor
Tutor
any updates ?
same issue here, even after 3months
ShayneS
Arlo Moderator
Arlo Moderator

Hi @qlin3

 

I have a few questions for you.

  • Which model/phone are you using & trying to add?
  • What version of Android are the devices running?
  • What version of the Arlo app are you using?
Rowben
Aspirant
Aspirant
I have tried this exactly as you instructed and still I get the same message saying it can't be done.
dcfox1
Master
Master

@Rowben   Is this error after you enabled the settings described in your pic in your phone settings.  I may have missed it in this long thread. 

Rowben
Aspirant
Aspirant
Yes, it's strange because she has exactly the same phone as me and has her settings the same. After she logged back into the arlo app after installing it again, the app even asked for location permission when she clicked the geofencing mode. She clicked "allow" and we thought we might have cracked it. But alas no.