Arlo|Smart Home Security|Wireless HD Security Cameras|NETGEAR

The Arlo Community

Learn, explore, ask questions, and connect with our community of customers and experts.

Discussion stats
  • 6 replies
  • 551 views
  • 0 kudos
  • 5 in conversation
Top Contributors
Caught on Arlo Video Contest
Share Video

Share Your Video!
Caught something cool on Arlo? Share it with the Arlo Community.

Post a video
Reply
Aspirant

Arlo App Won’t Let Me Create Account

Just bought a new Arlo Pro. Trying to set up a new account but the app says I have an account already. Tried logging in with my Netgear router email and pw which then prompts that I own Netgear products but new to arlo - asks if I want to set up arlo products. Select ‘yes’ but then asks for email address again. Once submitted it goes back to telling me an account already exists, and to login in. How do I get out of this never ending loop?

Model: VMC4030 | Arlo Pro Wire-Free Camera
Message 1 of 7
brh Master
Master

Arlo App Won’t Let Me Create Account

@jtsuno

What happens if you select NO instead of Yes? On a pc are you able to log in to https://arlo.netgear.com/#/login using your normal email credentials?

If so, try to add devices starting with your base station.

 

Brian

Message 2 of 7
Aspirant

Arlo App Won’t Let Me Create Account

@brh if I select 'no', nothing happens. It just keeps me on the login page.

 

I just tried logging in on desktop (mac) with same credentials, click login, nothing happens. 'Log In' button greys out, looks like it's thinking, but not taking me anywhere. Page has been open for 5 mins w/out refreshing.

 

This is pretty frustrating. Is my previous Netgear router login supposed to work with Arlo? It wasn't clear in the instructions that logins could/would be shared across Netgear devices. To be clear on the steps I've taken:

 

1. Tried to login through app as new user, but it threw a note that user name already exists. Not understanding how that would be possible, I realized that Arlo is a Netgear product so I tried my Nighthawk (router) app login.

2. Arlo app seems to accept that login but prompts that Arlo products don't currently exist, asks if I'd like to add. Select "Yes" and then it asks what my email address is again. Enter again. Then it tells me that the user exists. Then starts this neverending loop.

 

This cannot be a unique case in which customers previously own a Netgear product, if in fact that is what is causing this issue. 

Message 3 of 7
Arlo Moderator

Re: Arlo app won’t let me create account

@jtsuno

 

Have you contacted customer support regarding this issue?

Message 4 of 7
Aspirant

Re: Arlo app won’t let me create account

I have the same problem since I have Netgear ReadyCloud account already.

Message 5 of 7
Arlo Moderator

Re: Arlo app won’t let me create account

@lucaslarsen7

 

Have you previously contacted customer service regarding this?

Message 6 of 7
Ms0 Aspirant
Aspirant

Re: Arlo App Won’t Let Me Create Account

That happened to me also. You have to us a different email address. They said only till there system is upgraded 

Message 7 of 7