Arlo|Smart Home Security|Wireless HD Security Cameras

Re: Adobe Flash Player Update Failure

Reply
Discussion stats
GypseGym Follower
Follower

For the past three days I have not been able to do anything with my Arlo Pro cameras.  I get a message that I need a newer version of Adobe Flash Player.  I have gone through the process to download and install Adlobe Flash Player several dozen times.  No change.  I have a laptop with a current version of Windows 10.  I normally use Mozilla Firefox for browser.  However, I have also used Microsoft Edge on my laptop to access my Arlo account/cameras and get the exact same result as with Firefox.  I have read numerous threads and comments on the Arlo Community support web pages about problems with Adobe Flash Player.  I have not found any help that works for me.  Please tell me how to make the Adobe Flash Player update message go away and get my Arlo security camera videos to work again.  I desperately need my security camera system to work!  Thank you.


Accepted Solutions
Highlighted
Guru StephenB Guru
Guru

@PBou wrote:

Got the same problem, with firefox and Safari. No fix found so far...

 


Not sure if this is all available on the Mac, but perhaps try this with firefox

  1. log into my.arlo.com
  2. click "live" on a camera.  
  3. When the flash update message appears, a new icon appears between the i and the padlock in the address bar.  Click on that icon, and choose allow flash.  The icon should then change color.
  4. click on the "x" on the flash update message to dismiss it.
  5. click "live" again and it should work.

All Replies
Guru StephenB Guru
Guru

 


@GypseGym wrote:

Please tell me how to make the Adobe Flash Player update message go away and get my Arlo security camera videos to work again.  I desperately need my security camera system to work!  Thank you.


FWIW, I think everyone who uses the web client is wanting to see Flash removed.  I don't know how to make the message completely go away, but you can navigate past those warnings and use the web interface.  

 

With Chrome, you click on the padlock next to the address bar, and then select "Allow" for flash.  Do this before clicking on "Live" or accessing the video library.  There's a screenshot here: https://community.arlo.com/t5/Arlo-Pro/I-see-you-got-rid-of-Flash-but-once-again-an-update-breaks/m-... After you do this you will be prompted to reload the page (and flash will function after you do that).

 

FIrefox is similar (click on the i or lock icon next to the address), except I'm told that you disable "Content Blocking" instead of allowing Flash.

 

Edge is clumsiest.  I posted the steps (with screen shots) yesterday here: https://community.arlo.com/t5/Arlo-Pro/I-see-you-got-rid-of-Flash-but-once-again-an-update-breaks/m-...

 

Note that you only need the flash plugin with FireFox.  The other two browsers have flash built in (and it can't be updated without updating the browser).  So part of the problem here is that the message is confusing - in most cases Flash doesn't need to be updated.  Instead it needs to be enabled.

700rng Tutor
Tutor

yes, but chrome will not longer be supported after 2020

Guru StephenB Guru
Guru

@700rng wrote:

yes, but chrome will not longer be supported after 2020


December 2020... 

 

I hope Arlo gets to this sooner, because the "flash dance" gets old pretty quickly.  But I'm not going to stress over a planned deprecation that's still 15 months away.

BeachGal Initiate
Initiate

Did anyone get a fix for this?

 

I'm on an up to date Mac and am having the same issue on Firefox and Safari.  I've followed the above instructions ie:  turning of the blocking for this site, but it didn't fix the issue.  I've completely  removed Flash and then reloaded it, so I know it is the most up to date version.  If anyone has any other ideas it would be greatly appreciated.

Model: VMC4030 | Arlo Pro Wire-Free Camera
PBou Tutor
Tutor

Hi everyone,

 

Got the same problem, with firefox and Safari. No fix found so far...

I noticed that the login page has just changed, looks like Netgear changed something recently.

Model: VMB3000 | Arlo Base Station
PBou Tutor
Tutor

Android app is still working fine though

Highlighted
Guru StephenB Guru
Guru

@PBou wrote:

Got the same problem, with firefox and Safari. No fix found so far...

 


Not sure if this is all available on the Mac, but perhaps try this with firefox

  1. log into my.arlo.com
  2. click "live" on a camera.  
  3. When the flash update message appears, a new icon appears between the i and the padlock in the address bar.  Click on that icon, and choose allow flash.  The icon should then change color.
  4. click on the "x" on the flash update message to dismiss it.
  5. click "live" again and it should work.
Robert101 Aspirant
Aspirant
Worked great with Firefox. TY!
PBou Tutor
Tutor

Worked also for me, thank you!

(even if plugin icon did not change color btw)

vnwlim Aspirant
Aspirant

I have the same problem, use Window 10 and Firefox

 

I wonder why if Arlo Support team not look at the community posting and provide advice?

Guru StephenB Guru
Guru

@vnwlim wrote:

I have the same problem, use Window 10 and Firefox

 


Did the solution I posted earlier on this thread work for you?  

 

411TTWB Initiate
Initiate

Thanx!

Solved my problem - glad I found this solution amoung all the Adobe Flash Player threads!

Worked Great for Firefox  and Windows 10

 

Adober Flash Player was working fine on other sites using Firefox browser, just not on Arlo.

I had used the "add-on" Flash plus in which I can "whitelist" certain sites. This was not a fix. The solution you provided to select Adobe Flash Player grey Icon and select allow worked

Thank you

vnwlim Aspirant
Aspirant

Thank you. I can confirm is working now!

N2IDY Aspirant
Aspirant

I have the same problem, use Window 10 and Firefox.

Nothing works so far

Guru StephenB Guru
Guru

After you click on "live" and get the update error, you should see a "lego" icon next to the padlock in the address bar.

If you click on that you will see a control to allow flash.

After that you can exit the update error message (click on the x) and it should work.

N2IDY Aspirant
Aspirant
No LEGO icon showed up
411TTWB Initiate
Initiate

What is in the address bar where the URL is ?

On Firefox withWindows 10 one should see at minimum (depending on the add-ons) a circle with an i in it probably a "ghosted icon that looks like a lego which is the Adobe flash Player permission icon, and then a padlock icon . After that one sees the address such as https://community.arlo ...etc.

What do you have?

The issue is with the browser and the permission options one has selected with the browser. Well.... this is what I have learned. More specifically it is the browser and the arlo site, however it how the browser is protecting one from various sites. I cccccan get the same issues with the weather sites and resolved them with the solutions posted here

Guru StephenB Guru
Guru

@N2IDY wrote:
No LEGO icon showed up

Here's a screen shot of what I see

logo.png

The "lego" is the one immediately to the left of the padlock.  When you click on it and allow flash, the indicator will change color.

N2IDY Aspirant
Aspirant

Thank you. I was looking on the wrong side of the address bar... Works good now!!!

KKS-Col Apprentice
Apprentice

I just encountered this problem today (9/10/19) on computers using Firefox. I found this solution posted and it worked fine for me. Thanks; I never would have noticed the icon in the website bar.

Model: VMB4500 | Arlo Pro/Pro2 Base Station
NJSS Star
Star

The underlying problem is that Arlo needs Flash.

 

Adobe has stated it will end support for Flash in 2020, surely Arlo should rewrite its apps so that they don't need Flas as a matter or urgency.

 

NJSS

AndreasBi Tutor
Tutor

Pushing the "X" brings nothing at all, it want's to update...

JMS11 Tutor
Tutor

Thanks! That worked!

Model: VMB4000 | Arlo Pro/Pro2 Base Station
Guru StephenB Guru
Guru

@AndreasBi wrote:

Pushing the "X" brings nothing at all, it want's to update...


Read the earlier posts in the thread for the steps needed to enable flash.