Arlo|Smart Home Security|Wireless HD Security Cameras
× Urgent: Activate Two-Step Verification
Arlo requires all users to activate two-step verification to continue to access your recordings, devices, and account.
Please enable this feature now. Learn More.

How long does it take to charge? Camera doesn't flash blue light.

Reply
Discussion stats
  • 4 Replies
  • 266 Views
  • 0 Likes
  • 4 In Conversation
Aspirant
Aspirant

I received my 3 pack of Arlo 4 Pro cameras today.  I had to replace the piece of crap original arlo cameras finally.  I'm trying to charge a new camera and set it up.  How long does it take to charge?  Have you looked in the user manual for this answer?  Don't waste your time.  Find the answer on their 'support' pages?  That's a joke too.  The camera is supposed to flash a blue light while you point it at the QR code in the app.  There is no flashing blue light.  Nothing in the manual about this.  All I have is a repeated clicking sound from the camera.  Same on two of the cameras I tried.  I would try the other camera, but I need to charge at least one.  Three cameras and only ONE charging cable provided?  What moron came up with this?    I have no idea if this thing is charging or when I'll be able to connect to the internet and use the thing.  Is this how it is for other Pro 4 users?

Model: VMC4050P/VMC4041P | Arlo Pro 4
Guru Guru
Guru

There is no flashing blue LED other than when power is first connected. Since it seems to happen to all cameras and you're hearing a clicking, it sounds like the charger is the issue. Have you tried another one you have laying around that supplies 5v, 2A?

Tutor
Tutor

It took at least 6 hours to charge each of the cameras from what I remember.  The battery status in the Arlo app didn't seem to update regularly.  Sometimes if I unplugged the charger and then back in, the status would update.  Probably just another app bug. 

 

Model: VMC4050P/VMC4041P | Arlo Pro 4
Aspirant
Aspirant

   

So I had the clicking issue also on 2 cameras, then became disturbed that it would not auto connect on the pull and replace of battery. After 20 min I noticed the sync button on the inside of camera bottom and boom it synced up... not sure why clicks but wokrs great now. Had the pros and pro 2's and these are great also as they connect to same base. 

 

 

Model: VMC4050P/VMC4041P | Arlo Pro 4
Aspirant
Aspirant
 

any luck on a fix ??

Model: VMC4050P/VMC4041P | Arlo Pro 4
Discussion stats
  • 4 Replies
  • 267 Views
  • 0 Likes
  • 4 In Conversation