Arlo|Smart Home Security|Wireless HD Security Cameras

Pro 3 cloud recording

Reply
Discussion stats
  • 2 Replies
  • 170 Views
  • 0 Likes
  • 2 In Conversation
Cobrasmith
Aspirant
Aspirant
So I have been a long time customer of arlo products. I am an electrician by trade and I routinely recommend and install arlo systems for customers. I just want to say how disappointed I am with the direction they are moving with their subscription service. 1) the subscription prices are ridiculously over priced 2) they no longer give you 7 days free cloud recording which is all a lot of people cared about. 3) the local storage option is a joke, they limit you to 2tb of local storage and it saves the recording in 2k which can eat up your hd very quickly. I just did an install of 15 pro3 cameras for a customer without knowing that they quit the 7 day free cloud recording. They called me and said they had nothing in their library and thats because the free trial subscription just ended. I did do the port forwarding feature for them but either way it is just ridiculous. I am very disappointed in the greedy direction they are going and I definitely will not be recommending their products in the future. It’s not like the cost of the arlo system is so cheap that they need to make it up in a subscription, they are comparable in prices to a wired system. Sorry, I didn’t really have any questions, just wanted to vent at how greedy this company is getting. That was the last arlo system I will ever recommend to a customer.
Model: VMB4540 | Arlo Pro 3 SmartHub
2 REPLIES 2
dcfox1
Master
Master

The subscription change started several years ago with the release of the Ultra. The Pro2 and older still have the 7 day free storage. 

 I have a 32 GB USB stick and have not even got close after several months with 2K. 2TB would last long time. I do agree that it does need work on Local storage though. 

Model: VMB4540 | Arlo Pro 3 SmartHub
Cobrasmith
Aspirant
Aspirant
I wish I would have known that on the cloud recording. I have done all of the port forwarding for the last system I installed and it’s super glitchy. Sometimes it connects to local base, sometimes not. I have shared 2 other base units with the main act and they only show up in as a choice once in a while. The annoying thing is nothing is consistent. After I set up the port forwards it worked great for a few hours and then when the homeowner logged in all hell broke loose. This local recording needs a lot of work.
Discussion stats
  • 2 Replies
  • 171 Views
  • 0 Likes
  • 2 In Conversation