Arlo|Smart Home Security|Wireless HD Security Cameras|NETGEAR
Reply
Tutor

Arlo Baby - Randomly disconnects from HomeKit

I've been using Arlo Baby successfully with HomeKit for the past 6 months.

 

It has been quite reliable, but about 3 weeks ago (before the recent firmware update came out), I've started experiencing random disconnects from HomeKit.

 

Specifically:

  1. Launch the Home app on my iPad
  2. Open the camera feed
  3. Feed is on and working fine
  4. After a few minutes, says "Feed is unavailable" (or words to that effect)
  5. Remaining in the Home app, I close and reopen the feed and it immediately works again.

Previously, I could keep the feed open for hours at a time with no issues.

 

I've tried to diagnose it as follows:

  • Trying with a different device instead of iPad
  • Trying to move Arlo Baby nearer to the Wifi hotspot
  • Tried with alternative HomeKit apps to see if they're more resilient
  • Factory reset the Arlo, then re-added to HomeKit. Seemed to be more reliable for a day or two then resumed the issue.

Note that my Arlo is connected via the 5GHz access point (so I don't believe it's related to interference on 2.4GHz network).

Message 1 of 15
Tutor

Re: Arlo Baby - Randomly disconnects from HomeKit

One other note:

I ran the feed on the Arlo app on one device, and via HomeKit on another device.

When the Home app says “device not responding”, the Arlo app continues to work fine.

(The problem is though that there’s a 4-5 second delay on the Arlo app, so I prefer not to use it)
Message 2 of 15
Initiate

Re: Arlo Baby - Randomly disconnects from HomeKit

I am having this issue as well. I have been using Arlo Baby on Homekit without any issues since July 2018. In the last 3 weeks it has become completely unstable. I can view fine in the Arlo app however the Arlo App doesn't allow me to view picture and picture on my iPad, which is extremely important for me. The Apple Home app gives me this ability which is why it's my prefered viewer for the Arlo Baby feed.

I have tried resetting my Arlo Baby camera and re-adding to Homekit and this does not fix the issue.

 


@HendX wrote:

I've been using Arlo Baby successfully with HomeKit for the past 6 months.

 

It has been quite reliable, but about 3 weeks ago (before the recent firmware update came out), I've started experiencing random disconnects from HomeKit.

 

Specifically:

  1. Launch the Home app on my iPad
  2. Open the camera feed
  3. Feed is on and working fine
  4. After a few minutes, says "Feed is unavailable" (or words to that effect)
  5. Remaining in the Home app, I close and reopen the feed and it immediately works again.

Previously, I could keep the feed open for hours at a time with no issues.

 

I've tried to diagnose it as follows:

  • Trying with a different device instead of iPad
  • Trying to move Arlo Baby nearer to the Wifi hotspot
  • Tried with alternative HomeKit apps to see if they're more resilient
  • Factory reset the Arlo, then re-added to HomeKit. Seemed to be more reliable for a day or two then resumed the issue.

Note that my Arlo is connected via the 5GHz access point (so I don't believe it's related to interference on 2.4GHz network).


 

Message 3 of 15
Arlo Moderator

Re: Arlo Baby - Randomly disconnects from HomeKit

Have you tried contacting customer support regarding this issue? I have attached the link here for you - Arlo Tech Support

Message 4 of 15
Tutor

Re: Arlo Baby - Randomly disconnects from HomeKit

I have tried contacting support:

 

1) The live chat option didn't work (never connected me to anybody)

 

2) After hours, it is possible to send an email (via a webform), but this option throws an error when you try to submit.

 

Pretty bad experience.

Message 5 of 15
Aspirant

Re: Arlo Baby - Randomly disconnects from HomeKit

I have the same problem...

Message 6 of 15
Arlo Moderator

Re: Arlo Baby - Randomly disconnects from HomeKit

Hi @Jjteft

 

Have you tried using the following link to set the device up? How do I connect my Arlo Baby camera to The Apple Home app on my iOS device?

Message 7 of 15
Aspirant

Re: Arlo Baby - Randomly disconnects from HomeKit

I have gotten the device to connect by restarting it, it then disconnects 5-10 minutes later and I have to restart it again.
Message 8 of 15
Arlo Moderator

Re: Arlo Baby - Randomly disconnects from HomeKit

@Jjteft

 

I would suggest contacting customer support regarding this issue? I have attached the link here for you - Arlo tech Support

Message 9 of 15
Apprentice

Re: Arlo Baby - Randomly disconnects from HomeKit

Same problem. New problems with every update. What a disaster.
Message 10 of 15
Initiate

Re: Arlo Baby - Randomly disconnects from HomeKit

I have tried on 3 seperate occasions to contact support via live chat. All 3 times I just get an empty popup window that never connects to a service representitive. There's no option to email for support. I have tried using Firefox and Chrome since they are suggested browsers, as well as Safari and have never been able to connect with support.

The issue where HomeKit video feed loses it's connection with the Arlo Baby is still happening. This issue seems to have started after the last firmware update that was supposed to contain HomeKit fixes. I've also noticed that my camera seems to be randomly restarting at least once a day. 

One could argue that I can just use the Arlo App to view my feed - but if my internet connection goes down (which it does frequently living in a rural area) I can't use the app. I need to be able to use this monitor through HomeKit without interruptions. I was satisfied with this monitor until these issues started happening, and now I want to throw it as hard as I can out the window. How can you market a product to monitor babies that is so unreliable and provide such horrible support? I am lucky that I have a secondary way to monitor my child, because there is no way I could trust this as my only baby monitor!

Message 11 of 15
Highlighted
Apprentice

Re: Arlo Baby - Randomly disconnects from HomeKit

The irony of encountering broken customer support portals when attempting to resolve an issue with a broken device is amazing.
Message 12 of 15
Apprentice

Re: Arlo Baby - Randomly disconnects from HomeKit

I am experiencing the same issue.  They're infuriating, but I suppose you could say that Arlo has kept things interesting, as we get a new, crippling bug with every update!

 

So here is our current set of choices:

  1. Use Native Arlo App for the video feed.  You will be forced to endure constant and distracting pixelation in the video feed if you are on your local wifi networt (irrespective of the network's speed).  This experience makes me want to curl up in a ball and cry; 
  2. Use Native Arlo App for background audio.  This works until you attempt to open the app after a period of "always on"/background audio, at which point the feed will "re-load" and you will get two simultaneous, but out-of-sync, background audio feeds.  Similar to option 1, this experience makes me want to curl up in a ball and cry; or
  3. Use HomeKit (but don't you dare leave the room, unless you want to lose the video feed and receive an error message that "someone else is viewing the feed).  You are on the clock and this unpixelated feed will timeout shortly, at which point you will be given an error message that the camera  is "not responding."  You can try reloading the feed, but this will happen over and over and over and over and over and over.  This experience makes me want to curl up in a ball and cry.

 

Make sure you open a support case, as I have done on 3-4 occasions, to discuss these issues with "level 2" support.  Nothing personal against the tech support individuals, but no resolution has come of any of my interactions with this department.  They will call you and leave messages.  They might discuss over the phone.  They might say your device is defective and we're sending you a new one, but your device is not defective.  They might close your case without resolving it.  One thing is certain, they will NOT resolve your case.

 

The HomeKit "someone else is watching the feed" bug has existed since I've owned the product.  The pixelated videofeed in the native Arlo App has existed since I've owned the product.  Arlo Software/Firmware technicians are absymal and by implication, so is the entire company.  The Arlo Baby has a lot of potential in its hardware, but I've never purchased a more poorly supported device from a major manufacturer.  The fact that Arlo continues to release products is borderline hilarious, as the software support potentially warrants legal action, as I've mentioned in the past.  Unfair and deceptive trade practices is a legitimate cause of action in many states across America and brings with it treble damages.  Just saying.

Message 13 of 15
Apprentice

Re: Arlo Baby - Randomly disconnects from HomeKit

@shayneC

When are we getting an update on a fix for this issue?
Message 14 of 15
Aspirant

Re: Arlo Baby - Randomly disconnects from HomeKit

I have the same problem and no solution ahead...

Message 15 of 15